summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-13 02:32:51 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-13 02:32:51 +0000
commitb6ac72d486a2a0122d2789d605106bffac508e08 (patch)
tree4f24ba78a2b850f250558c5ca8f922b76af54077 /x11-plugins/wmtimer
parentversion bump from upstream. fixes bug #200504 (diff)
downloadgentoo-2-b6ac72d486a2a0122d2789d605106bffac508e08.tar.gz
gentoo-2-b6ac72d486a2a0122d2789d605106bffac508e08.tar.bz2
gentoo-2-b6ac72d486a2a0122d2789d605106bffac508e08.zip
Version bump to correct versioning scheme.
(Portage version: 2.1.4, RepoMan options: --force)
Diffstat (limited to 'x11-plugins/wmtimer')
-rw-r--r--x11-plugins/wmtimer/ChangeLog10
-rw-r--r--x11-plugins/wmtimer/files/digest-wmtimer-2.92 (renamed from x11-plugins/wmtimer/files/digest-wmtimer-2.9.2)0
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.9.2.ebuild41
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.92.ebuild39
4 files changed, 47 insertions, 43 deletions
diff --git a/x11-plugins/wmtimer/ChangeLog b/x11-plugins/wmtimer/ChangeLog
index ada21a35bcbc..8b5a592b2b2c 100644
--- a/x11-plugins/wmtimer/ChangeLog
+++ b/x11-plugins/wmtimer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmtimer
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/ChangeLog,v 1.21 2006/10/10 07:59:54 s4t4n Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/ChangeLog,v 1.22 2008/01/13 02:32:50 drac Exp $
+
+*wmtimer-2.92 (13 Jan 2008)
+
+ 13 Jan 2008; Samuli Suominen <drac@gentoo.org> -wmtimer-2.9.2.ebuild,
+ +wmtimer-2.92.ebuild:
+ Version bump to correct versioning scheme with a new ebuild.
10 Oct 2006; Michele Noberasco <blubb@gentoo.org> wmtimer-2.9.2.ebuild:
Added missing libXpm dependancy, closing bug #150656.
diff --git a/x11-plugins/wmtimer/files/digest-wmtimer-2.9.2 b/x11-plugins/wmtimer/files/digest-wmtimer-2.92
index 2ae86b76991e..2ae86b76991e 100644
--- a/x11-plugins/wmtimer/files/digest-wmtimer-2.9.2
+++ b/x11-plugins/wmtimer/files/digest-wmtimer-2.92
diff --git a/x11-plugins/wmtimer/wmtimer-2.9.2.ebuild b/x11-plugins/wmtimer/wmtimer-2.9.2.ebuild
deleted file mode 100644
index b1388373ee8a..000000000000
--- a/x11-plugins/wmtimer/wmtimer-2.9.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.9.2.ebuild,v 1.7 2006/10/10 07:59:54 s4t4n Exp $
-
-IUSE=""
-
-MY_PV="2.92"
-MY_P="${PN}-${MY_PV}"
-
-S=${WORKDIR}/${MY_P}/${PN}
-
-DESCRIPTION="Dockable clock which can run in alarm, countdown timer or chronograph mode"
-SRC_URI="http://www.darkops.net/wmtimer/${MY_P}.tar.gz"
-HOMEPAGE="http://www.darkops.net/wmtimer/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
-
-RDEPEND=">=x11-libs/gtk+-2.6.2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.15.0
- >=sys-apps/sed-4.0.9
- >=x11-libs/libXpm-3.5.5"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i -e "s:-O2 -Wall:${CFLAGS}:" Makefile
-}
-
-src_compile() {
- emake || die
-}
-
-src_install () {
- dobin wmtimer
- cd ..
- dodoc README CREDITS Changelog
-}
diff --git a/x11-plugins/wmtimer/wmtimer-2.92.ebuild b/x11-plugins/wmtimer/wmtimer-2.92.ebuild
new file mode 100644
index 000000000000..02542fe2cd74
--- /dev/null
+++ b/x11-plugins/wmtimer/wmtimer-2.92.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.92.ebuild,v 1.1 2008/01/13 02:32:50 drac Exp $
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Dockable clock which can run in alarm, countdown timer or chronograph mode"
+HOMEPAGE="http://www.darkops.net/wmtimer"
+SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:-g:${CFLAGS}:g" -e "s:-O2::" -i Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ LIBDIR="-L/usr/$(get_libdir)" || die "emake failed."
+}
+
+src_install() {
+ dobin wmtimer
+ dodoc ../{Changelog,CREDITS,README}
+}