summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-17 14:24:57 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-17 14:24:57 +0000
commitb5c85a56a49c26867339712324925fbeceb9782a (patch)
tree26407ce7bf61264e1d062cd818d25d38babbcc7c /x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild
parent (Manifest recommit) (diff)
downloadgentoo-2-b5c85a56a49c26867339712324925fbeceb9782a.tar.gz
gentoo-2-b5c85a56a49c26867339712324925fbeceb9782a.tar.bz2
gentoo-2-b5c85a56a49c26867339712324925fbeceb9782a.zip
Initial import of x11-plugins/wmlongrun, versino 0.2.0. Closes #52894
Diffstat (limited to 'x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild')
-rw-r--r--x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild b/x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild
new file mode 100644
index 000000000000..c5729fa7de1f
--- /dev/null
+++ b/x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlongrun/wmlongrun-0.2.0.ebuild,v 1.1 2004/07/17 14:24:57 s4t4n Exp $
+
+DESCRIPTION="A dockapp to monitor LongRun on a Transmeta Crusoe processor"
+HOMEPAGE="http://www.sh.rim.or.jp/~ssato/dockapp/index.shtml"
+SRC_URI="http://www.sh.rim.or.jp/~ssato/src/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="virtual/x11"
+IUSE=""
+
+# Since this will only work with a Crusoe processor, it's safe to assume that
+# the functionality is only available on x86.
+KEYWORDS="~x86 -*"
+
+src_compile() {
+ econf || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+ dodoc README AUTHORS TODO COPYING MAKEDEV-cpuid-msr
+}