summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-12 14:39:08 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-12 14:39:08 +0000
commit35b9063d63672e884554e98f73897f29f712e502 (patch)
treecfc6cb32f966e48147634b8ba7377e56c2d5763a /x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
parentremove useless mpeg USE-flag, add fontconfig USE-flag and correct freetype co... (diff)
downloadgentoo-2-35b9063d63672e884554e98f73897f29f712e502.tar.gz
gentoo-2-35b9063d63672e884554e98f73897f29f712e502.tar.bz2
gentoo-2-35b9063d63672e884554e98f73897f29f712e502.zip
Ported to GTK+-2.0.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild')
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
new file mode 100644
index 000000000000..c696fc517251
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild,v 1.1 2008/01/12 14:39:07 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gtk.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README
+}