summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-17 22:07:32 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-17 22:07:32 +0000
commitb1df5f15516db8973e45faaf044b628cc73d0a33 (patch)
tree32f146a7cc709343796f86aa6e7ee7beb033dcf9 /x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild
parentstable on ppc64, bug #55805 (Manifest recommit) (diff)
downloadgentoo-2-b1df5f15516db8973e45faaf044b628cc73d0a33.tar.gz
gentoo-2-b1df5f15516db8973e45faaf044b628cc73d0a33.tar.bz2
gentoo-2-b1df5f15516db8973e45faaf044b628cc73d0a33.zip
Initial import of x11-plugins/wmcdplay, version 1.0_beta1. Closes #54550
Diffstat (limited to 'x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild')
-rw-r--r--x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild b/x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild
new file mode 100644
index 000000000000..56f4675d116e
--- /dev/null
+++ b/x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild,v 1.1 2004/07/17 22:07:32 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P=${P/_beta/-beta}
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="CD player applet for WindowMaker"
+SRC_URI="http://www.geocities.com/SiliconValley/Vista/2471/files/${MY_P}.tgz"
+HOMEPAGE="http://www.geocities.com/SiliconValley/Vista/2471/"
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-xpmdir.patch
+ epatch ${FILESDIR}/${PN}-ComplexProgramTargetNoMan.patch
+ epatch ${FILESDIR}/${PN}-c++.patch
+}
+
+src_compile()
+{
+ PATH=${PATH}:/usr/X11R6/bin
+ xmkmf || die "xmkmf failed"
+ emake CDEBUGFLAGS="${CFLAGS}" || die "Compilation failed"
+}
+
+src_install()
+{
+ einstall DESTDIR="${D}" BINDIR="/usr/bin" || die "Installation failed"
+
+ insinto /usr/share/WMcdplay
+ doins XPM/*.art
+
+ dodoc ARTWORK README
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}