summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-01-12 16:58:21 +0000
committerJeroen Roovers <jer@gentoo.org>2013-01-12 16:58:21 +0000
commitf81c0393323134bec24b084d1fadffe65bc855fe (patch)
tree8ace24411076c2096078e7c7dd69f26d15ec0bab /x11-misc
parentrewrite linker scripts and symlinks too when moving lib32 (diff)
downloadgentoo-2-f81c0393323134bec24b084d1fadffe65bc855fe.tar.gz
gentoo-2-f81c0393323134bec24b084d1fadffe65bc855fe.tar.bz2
gentoo-2-f81c0393323134bec24b084d1fadffe65bc855fe.zip
Fix compiling with GCC 4.7 (bug #422039).
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/lineak-defaultplugin/ChangeLog11
-rw-r--r--x11-misc/lineak-defaultplugin/files/lineak-defaultplugin-0.9.0-gcc47.patch10
-rw-r--r--x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r1.ebuild47
3 files changed, 66 insertions, 2 deletions
diff --git a/x11-misc/lineak-defaultplugin/ChangeLog b/x11-misc/lineak-defaultplugin/ChangeLog
index cc6a5557d317..720852d7bc09 100644
--- a/x11-misc/lineak-defaultplugin/ChangeLog
+++ b/x11-misc/lineak-defaultplugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/lineak-defaultplugin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineak-defaultplugin/ChangeLog,v 1.28 2011/03/23 16:39:14 signals Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineak-defaultplugin/ChangeLog,v 1.29 2013/01/12 16:58:20 jer Exp $
+
+*lineak-defaultplugin-0.9.0-r1 (12 Jan 2013)
+
+ 12 Jan 2013; Jeroen Roovers <jer@gentoo.org>
+ +lineak-defaultplugin-0.9.0-r1.ebuild,
+ +files/lineak-defaultplugin-0.9.0-gcc47.patch:
+ Fix compiling with GCC 4.7 (bug #422039).
23 Mar 2011; Kevin McCarthy <signals@gentoo.org>
lineak-defaultplugin-0.9.0.ebuild:
diff --git a/x11-misc/lineak-defaultplugin/files/lineak-defaultplugin-0.9.0-gcc47.patch b/x11-misc/lineak-defaultplugin/files/lineak-defaultplugin-0.9.0-gcc47.patch
new file mode 100644
index 000000000000..7f593ef0818b
--- /dev/null
+++ b/x11-misc/lineak-defaultplugin/files/lineak-defaultplugin-0.9.0-gcc47.patch
@@ -0,0 +1,10 @@
+--- a/default_plugin/defaultplugin.cpp
++++ b/default_plugin/defaultplugin.cpp
+@@ -35,6 +35,7 @@
+ #include <iostream>
+ #include <sstream>
+ #include <stdlib.h>
++#include <unistd.h> /* fork() */
+ #include <cstring>
+ using namespace std;
+ using namespace lineak_core_functions;
diff --git a/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r1.ebuild b/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..87bbcba2f08d
--- /dev/null
+++ b/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r1.ebuild,v 1.1 2013/01/12 16:58:20 jer Exp $
+
+EAPI=5
+inherit eutils multilib
+
+MY_P=${P/.0/}
+
+DESCRIPTION="Mute/unmute and other macros for LINEAK"
+HOMEPAGE="http://lineak.sourceforge.net"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="
+ =x11-misc/lineakd-${PV}*
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/inputproto
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' default_plugin/Makefile
+}
+
+src_configure() {
+ econf USER_LDFLAGS="${LDFLAGS}" $(use_enable debug)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PLUGINDIR=/usr/$(get_libdir)/lineakd/plugins \
+ install
+ dodoc AUTHORS README
+}