summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2007-10-27 18:02:38 +0000
committerChristoph Mende <angelos@gentoo.org>2007-10-27 18:02:38 +0000
commitc7b04516728e5f6793554626d57311dbe23e5b57 (patch)
treedde2e156237463c760cd6c6cf43a5b5b1aaa680d /x11-misc
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-c7b04516728e5f6793554626d57311dbe23e5b57.tar.gz
gentoo-2-c7b04516728e5f6793554626d57311dbe23e5b57.tar.bz2
gentoo-2-c7b04516728e5f6793554626d57311dbe23e5b57.zip
Fixed PAM handling, bug 197225 by Florian Wagner
(Portage version: 2.1.3.16)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slim/ChangeLog7
-rw-r--r--x11-misc/slim/files/digest-slim-1.3.0-r13
-rw-r--r--x11-misc/slim/slim-1.3.0-r1.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/x11-misc/slim/ChangeLog b/x11-misc/slim/ChangeLog
index ffd7d5aa999a..24bd4095fdec 100644
--- a/x11-misc/slim/ChangeLog
+++ b/x11-misc/slim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/slim
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.8 2007/09/08 12:08:46 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.9 2007/10/27 18:02:37 angelos Exp $
+
+*slim-1.3.0-r1 (27 Oct 2007)
+
+ 27 Oct 2007; Christoph Mende <angelos@gentoo.org> +slim-1.3.0-r1.ebuild:
+ Fixed PAM handling, bug 197225 by Florian Wagner
08 Sep 2007; nixnut <nixnut@gentoo.org> slim-1.3.0.ebuild:
Added ~ppc wrt bug 188305
diff --git a/x11-misc/slim/files/digest-slim-1.3.0-r1 b/x11-misc/slim/files/digest-slim-1.3.0-r1
new file mode 100644
index 000000000000..90302a8017c0
--- /dev/null
+++ b/x11-misc/slim/files/digest-slim-1.3.0-r1
@@ -0,0 +1,3 @@
+MD5 1c1a87f3cbd3c334c874585e42701961 slim-1.3.0.tar.gz 218646
+RMD160 80205d8e757c76f9c0e21263ec38624f605d9586 slim-1.3.0.tar.gz 218646
+SHA256 b3cb736ce567146e9bdb5e081fce95d4ec69d64ccc30d004e921823b54c44e9b slim-1.3.0.tar.gz 218646
diff --git a/x11-misc/slim/slim-1.3.0-r1.ebuild b/x11-misc/slim/slim-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..25ccec727014
--- /dev/null
+++ b/x11-misc/slim/slim-1.3.0-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.0-r1.ebuild,v 1.1 2007/10/27 18:02:37 angelos Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple Login Manager"
+HOMEPAGE="http://slim.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="pam"
+
+DEPEND="x11-proto/xproto
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXft
+ media-libs/libpng
+ media-libs/jpeg
+ pam? ( virtual/pam )"
+RDEPEND="${DEPEND}
+ media-fonts/corefonts"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # respect C[XX]FLAGS, fix crosscompile,
+ # fix linking order for --as-needed"
+ sed -i -e "s:^CXX=.*:CXX=$(tc-getCXX) ${CXXFLAGS}:" \
+ -e "s:^CC=.*:CC=$(tc-getCC) ${CFLAGS}:" \
+ -e "s:^MANDIR=.*:MANDIR=/usr/share/man:" \
+ -e "s:/usr/X11R6:/usr:" \
+ -e "s:^\t\(.*\)\ \$(LDFLAGS)\ \(.*\):\t\1\ \2\ \$(LDFLAGS):g" \
+ Makefile || die 'sed failed in Makefile'
+
+ # Remove all X11R6 references from slim.conf
+ # Set slim to daemon mode as default to stop xdm runscript from throwing errors on stop
+ # Set the default logfile to /dev/null to avoid cluttering up the harddisk
+ # as slim puts a lot of garbage in its logfile
+ sed -i -e 's#X11R6/##g' -e 's#/usr/bin:##' \
+ -e 's/# daemon/daemon/' \
+ -e 's#/var/log/slim.log#/dev/null#g' \
+ slim.conf || die "sed failed in slim.conf"
+}
+
+src_compile() {
+ if use pam ; then
+ emake USE_PAM=1 || die "emake failed."
+ else
+ emake || die "emake failed."
+ fi
+}
+
+src_install() {
+ if use pam ; then
+ emake USE_PAM=1 DESTDIR="${D}" install || die "emake install failed."
+ else
+ emake DESTDIR="${D}" install || die "emake install failed."
+ fi
+
+ dodoc xinitrc.sample ChangeLog README TODO THEMES
+}
+
+pkg_postinst() {
+ elog
+ elog "The configuration file is located at /etc/slim.conf."
+ elog "If you wish ${PN} to start automatically, set DISPLAYMANAGER=\"${PN}\" "
+ elog "in /etc/conf.d/xdm and run \"rc-update add xdm default\"."
+ elog
+ elog "${PN} uses .xinitrc in the user's home directory and /etc/slim.conf"
+ elog "for session management. For further information, see README and"
+ elog "xinitrc.sample in /usr/share/doc/${PF}."
+ elog
+ if use pam ; then
+ elog "You need to create /etc/pam.d/slim for SLiM to work."
+ elog "A simple symlink to /etc/pam.d/system-auth is enough,"
+ elog "if you don't need any extra configuration"
+ elog
+ fi
+}