summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-12-09 15:38:57 +0000
committerJeroen Roovers <jer@gentoo.org>2014-12-09 15:38:57 +0000
commit6a11942db2a106220ce482bba6b90ee6e9d5224c (patch)
tree583c211f242f9d8eea3b9fc6ca46ea9af4da8485 /x11-misc
parentVersion bump. Remove old. (diff)
downloadgentoo-2-6a11942db2a106220ce482bba6b90ee6e9d5224c.tar.gz
gentoo-2-6a11942db2a106220ce482bba6b90ee6e9d5224c.tar.bz2
gentoo-2-6a11942db2a106220ce482bba6b90ee6e9d5224c.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/ChangeLog8
-rw-r--r--x11-misc/rofi/files/rofi-0.14.12-run_test_sh.patch13
-rw-r--r--x11-misc/rofi/rofi-0.14.12.ebuild46
3 files changed, 66 insertions, 1 deletions
diff --git a/x11-misc/rofi/ChangeLog b/x11-misc/rofi/ChangeLog
index c6bb80376fed..d6e7ea09112b 100644
--- a/x11-misc/rofi/ChangeLog
+++ b/x11-misc/rofi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/rofi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rofi/ChangeLog,v 1.2 2014/10/06 08:48:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rofi/ChangeLog,v 1.3 2014/12/09 15:38:57 jer Exp $
+
+*rofi-0.14.12 (09 Dec 2014)
+
+ 09 Dec 2014; Jeroen Roovers <jer@gentoo.org> +rofi-0.14.12.ebuild,
+ +files/rofi-0.14.12-run_test_sh.patch:
+ Version bump.
06 Oct 2014; Jeroen Roovers <jer@gentoo.org> rofi-0.14.9.ebuild:
Setting --disable-gcov would of course enable it.
diff --git a/x11-misc/rofi/files/rofi-0.14.12-run_test_sh.patch b/x11-misc/rofi/files/rofi-0.14.12-run_test_sh.patch
new file mode 100644
index 000000000000..980c45e2312f
--- /dev/null
+++ b/x11-misc/rofi/files/rofi-0.14.12-run_test_sh.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -120,10 +120,3 @@
+ test: ${bin_PROGRAMS}
+ ./rofi_test
+ ./helper_test
+- $(top_srcdir)/test/run_test.sh 123 $(top_builddir)/textbox_test $(top_builddir) $(top_srcdir)/doc/example.xresources
+- $(top_srcdir)/test/run_test.sh 200 $(top_srcdir)/test/run_errormsg_test.sh $(top_builddir) $(top_srcdir)/doc/example.xresources
+- $(top_srcdir)/test/run_test.sh 201 $(top_srcdir)/test/run_switchdialog_test.sh $(top_builddir) $(top_srcdir)/doc/example.xresources
+- $(top_srcdir)/test/run_test.sh 202 $(top_srcdir)/test/run_dmenu_test.sh $(top_builddir) $(top_srcdir)/doc/example.xresources
+- $(top_srcdir)/test/run_test.sh 203 $(top_srcdir)/test/run_dmenu_custom_test.sh $(top_builddir) $(top_srcdir)/doc/example.xresources
+- $(top_srcdir)/test/run_test.sh 204 $(top_srcdir)/test/run_run_test.sh $(top_builddir) $(top_srcdir)/doc/example.xresources
+- $(top_srcdir)/test/run_test.sh 205 $(top_srcdir)/test/run_script_test.sh $(top_builddir) $(top_srcdir)/doc/example.xresources
diff --git a/x11-misc/rofi/rofi-0.14.12.ebuild b/x11-misc/rofi/rofi-0.14.12.ebuild
new file mode 100644
index 000000000000..90c3355ecb79
--- /dev/null
+++ b/x11-misc/rofi/rofi-0.14.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rofi/rofi-0.14.12.ebuild,v 1.1 2014/12/09 15:38:57 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://davedavenport.github.io/rofi/"
+SRC_URI="https://github.com/DaveDavenport/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="i3"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/pango
+ i3? ( x11-wm/i3 )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.14.9-optional-i3.patch \
+ "${FILESDIR}"/${PN}-0.14.12-run_test_sh.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with i3)
+}
+
+src_test() {
+ emake test
+}