summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-13 02:52:07 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-13 02:52:07 +0000
commit5b4a4c04c6418b0b461bd3bb08465779f5dcd8dd (patch)
tree63846202673829acfbe65eb34bdc1fa1bcc2bd86 /x11-misc
parentfix sed (diff)
downloadgentoo-2-5b4a4c04c6418b0b461bd3bb08465779f5dcd8dd.tar.gz
gentoo-2-5b4a4c04c6418b0b461bd3bb08465779f5dcd8dd.tar.bz2
gentoo-2-5b4a4c04c6418b0b461bd3bb08465779f5dcd8dd.zip
toolchanify and stable on amd64.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bbrun/ChangeLog7
-rw-r--r--x11-misc/bbrun/bbrun-1.6.ebuild24
2 files changed, 19 insertions, 12 deletions
diff --git a/x11-misc/bbrun/ChangeLog b/x11-misc/bbrun/ChangeLog
index 08d623319b2d..9701cd1c07b2 100644
--- a/x11-misc/bbrun/ChangeLog
+++ b/x11-misc/bbrun/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/bbrun
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/ChangeLog,v 1.20 2007/03/19 01:28:53 kloeri Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/ChangeLog,v 1.21 2008/01/13 02:52:07 drac Exp $
+
+ 13 Jan 2008; Samuli Suominen <drac@gentoo.org> bbrun-1.6.ebuild:
+ toolchanify and stable on amd64.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/x11-misc/bbrun/bbrun-1.6.ebuild b/x11-misc/bbrun/bbrun-1.6.ebuild
index 2261ff7c16f7..ff0bd090e4e1 100644
--- a/x11-misc/bbrun/bbrun-1.6.ebuild
+++ b/x11-misc/bbrun/bbrun-1.6.ebuild
@@ -1,32 +1,36 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/bbrun-1.6.ebuild,v 1.6 2006/12/04 01:22:16 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/bbrun-1.6.ebuild,v 1.7 2008/01/13 02:52:07 drac Exp $
+
+inherit multilib toolchain-funcs
DESCRIPTION="blackbox program execution dialog box"
-HOMEPAGE="http://www.darkops.net/bbrun/"
+HOMEPAGE="http://www.darkops.net/bbrun"
SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ppc sparc x86"
+KEYWORDS="amd64 ppc sparc x86"
IUSE=""
RDEPEND=">=x11-libs/gtk+-2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+S=${WORKDIR}/${P}/${PN}
+
src_unpack() {
unpack ${A}
- cd "${S}/bbrun"
- sed -i "s:-g -c -O2:-c ${CFLAGS}:" Makefile || die "sed Makefile failed"
+ cd "${S}"
+ sed -e "s:-O2::" -e "s:-g:${CFLAGS}:g" -i Makefile
}
src_compile() {
- cd "${S}/bbrun"
- emake || die "emake failed"
+ emake CC="$(tc-getCC)" \
+ LIBDIR="-L/usr/$(get_libdir)" || die "emake failed."
}
src_install () {
- dobin bbrun/bbrun || die "failed to install bbrun"
- dodoc Changelog README
+ dobin ${PN}
+ dodoc ../{Changelog,README}
}