summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVikraman Choudhury <vikraman@gentoo.org>2015-07-19 19:51:49 +0000
committerVikraman Choudhury <vikraman@gentoo.org>2015-07-19 19:51:49 +0000
commit4ad722b02b1224dfdfd49bcb87f5b2e44475880a (patch)
tree958a7df024836a3033d0ddb7710f3f1ae4777428 /x11-misc
parentx86 stable wrt bug #554906 (diff)
downloadgentoo-2-4ad722b02b1224dfdfd49bcb87f5b2e44475880a.tar.gz
gentoo-2-4ad722b02b1224dfdfd49bcb87f5b2e44475880a.tar.bz2
gentoo-2-4ad722b02b1224dfdfd49bcb87f5b2e44475880a.zip
Bump to version 1.1.0. Fixes bug 543340.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key B0A72FD2)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dunst/ChangeLog10
-rw-r--r--x11-misc/dunst/dunst-1.1.0.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/x11-misc/dunst/ChangeLog b/x11-misc/dunst/ChangeLog
index b2a5d71bcf46..bbc434e02065 100644
--- a/x11-misc/dunst/ChangeLog
+++ b/x11-misc/dunst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/dunst
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dunst/ChangeLog,v 1.6 2014/05/08 05:59:22 wired Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dunst/ChangeLog,v 1.7 2015/07/19 19:51:49 vikraman Exp $
+
+*dunst-1.1.0 (19 Jul 2015)
+
+ 19 Jul 2015; Vikraman Choudhury (vikraman) <vikraman@gentoo.org>
+ +dunst-1.1.0.ebuild:
+ Bump to version 1.1.0. Fixes bug 543340.
*dunst-1.0.0-r1 (08 May 2014)
diff --git a/x11-misc/dunst/dunst-1.1.0.ebuild b/x11-misc/dunst/dunst-1.1.0.ebuild
new file mode 100644
index 000000000000..8268333a80ce
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dunst/dunst-1.1.0.ebuild,v 1.1 2015/07/19 19:51:49 vikraman Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="customizable and lightweight notification-daemon"
+HOMEPAGE="http://www.knopwob.org/dunst/"
+SRC_URI="http://www.knopwob.org/public/dunst-release/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dunstify"
+
+CDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxdg-basedir
+ sys-apps/dbus
+ x11-libs/libXScrnSaver
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/cairo[X,glib]
+ x11-libs/pango[X]
+ dunstify? ( x11-libs/libnotify )
+"
+
+DEPEND="${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ # Remove nasty CFLAGS which override user choice
+ sed -ie "/^CFLAGS/ {
+ s:-g::
+ s:-O.::
+ }" config.mk || die "sed failed"
+
+ epatch_user
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ if use dunstify; then
+ dobin dunstify
+ fi
+
+ dodoc CHANGELOG
+}