summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-05-03 03:53:55 +0000
committerJeroen Roovers <jer@gentoo.org>2012-05-03 03:53:55 +0000
commit2514c55ce31d9807e3b0aa2d97f1d21d7cef88ec (patch)
tree7e448be8a55e74dbfc9e5b7b18bd8fdf9980f324 /x11-misc
parentDrop old. Add kernel_linux to IUSE. (diff)
downloadgentoo-2-2514c55ce31d9807e3b0aa2d97f1d21d7cef88ec.tar.gz
gentoo-2-2514c55ce31d9807e3b0aa2d97f1d21d7cef88ec.tar.bz2
gentoo-2-2514c55ce31d9807e3b0aa2d97f1d21d7cef88ec.zip
Fix building against dev-libs/glib-2.32 by Derk W te Bokkel (bug #414389).
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xpad/ChangeLog8
-rw-r--r--x11-misc/xpad/files/xpad-4.1-glib_includes.patch14
-rw-r--r--x11-misc/xpad/xpad-4.1.ebuild9
3 files changed, 27 insertions, 4 deletions
diff --git a/x11-misc/xpad/ChangeLog b/x11-misc/xpad/ChangeLog
index d8a8ae82b7c5..91f6fde37583 100644
--- a/x11-misc/xpad/ChangeLog
+++ b/x11-misc/xpad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xpad
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xpad/ChangeLog,v 1.70 2011/12/29 18:07:05 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xpad/ChangeLog,v 1.71 2012/05/03 03:53:55 jer Exp $
+
+ 03 May 2012; Jeroen Roovers <jer@gentoo.org> xpad-4.1.ebuild,
+ +files/xpad-4.1-glib_includes.patch:
+ Fix building against dev-libs/glib-2.32 by Derk W te Bokkel (bug #414389).
*xpad-4.1 (29 Dec 2011)
diff --git a/x11-misc/xpad/files/xpad-4.1-glib_includes.patch b/x11-misc/xpad/files/xpad-4.1-glib_includes.patch
new file mode 100644
index 000000000000..752e9ca551a6
--- /dev/null
+++ b/x11-misc/xpad/files/xpad-4.1-glib_includes.patch
@@ -0,0 +1,14 @@
+Description: Don't directly include glib2 header files.
+Author: Kyrill Detinov <lazy.kent@opensuse.org>
+Index: src/xpad-undo.c
+===================================================================
+--- a/src/xpad-undo.c
++++ b/src/xpad-undo.c
+@@ -23,7 +23,6 @@ Foundation, Inc., 59 Temple Place, Suite
+ #include "../config.h"
+ #include <stdlib.h>
+ #include <glib.h>
+-#include <glib/glist.h>
+ #include "xpad-undo.h"
+ #include "xpad-text-buffer.h"
+
diff --git a/x11-misc/xpad/xpad-4.1.ebuild b/x11-misc/xpad/xpad-4.1.ebuild
index 361aa0ce4549..4eb39d8f4618 100644
--- a/x11-misc/xpad/xpad-4.1.ebuild
+++ b/x11-misc/xpad/xpad-4.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xpad/xpad-4.1.ebuild,v 1.1 2011/12/29 18:07:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xpad/xpad-4.1.ebuild,v 1.2 2012/05/03 03:53:55 jer Exp $
EAPI=4
+inherit eutils
DESCRIPTION="A GTK+ 2.0 based 'post-it' note system."
HOMEPAGE="http://mterry.name/xpad"
@@ -28,3 +29,7 @@ DEPEND="
"
DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glib_includes.patch
+}