summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-19 09:54:39 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-19 09:54:39 +0000
commitb3b1e6bea77002f762963412923c9e76e1de1f4f (patch)
tree40d1365d2af338c34433449b068b91f1a8e8522b /x11-misc/xrestop
parentadd Harold Naparst as co-maintainer (diff)
downloadgentoo-2-b3b1e6bea77002f762963412923c9e76e1de1f4f.tar.gz
gentoo-2-b3b1e6bea77002f762963412923c9e76e1de1f4f.tar.bz2
gentoo-2-b3b1e6bea77002f762963412923c9e76e1de1f4f.zip
Fix building against sys-libs/ncurses[tinfo] (bug #529782).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/xrestop')
-rw-r--r--x11-misc/xrestop/ChangeLog8
-rw-r--r--x11-misc/xrestop/files/xrestop-0.4-tinfo.patch10
-rw-r--r--x11-misc/xrestop/xrestop-0.4.ebuild28
3 files changed, 34 insertions, 12 deletions
diff --git a/x11-misc/xrestop/ChangeLog b/x11-misc/xrestop/ChangeLog
index 79d6aa1e8d78..e39f2d3f7be3 100644
--- a/x11-misc/xrestop/ChangeLog
+++ b/x11-misc/xrestop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xrestop
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrestop/ChangeLog,v 1.28 2007/05/30 16:58:19 armin76 Exp $
+# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrestop/ChangeLog,v 1.29 2014/11/19 09:54:39 jer Exp $
+
+ 19 Nov 2014; Jeroen Roovers <jer@gentoo.org> xrestop-0.4.ebuild,
+ +files/xrestop-0.4-tinfo.patch:
+ Fix building against sys-libs/ncurses[tinfo] (bug #529782).
30 May 2007; Raúl Porcel <armin76@gentoo.org> xrestop-0.4.ebuild:
alpha stable wrt #157780
diff --git a/x11-misc/xrestop/files/xrestop-0.4-tinfo.patch b/x11-misc/xrestop/files/xrestop-0.4-tinfo.patch
new file mode 100644
index 000000000000..ef2de121e839
--- /dev/null
+++ b/x11-misc/xrestop/files/xrestop-0.4-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -65,6 +65,7 @@
+
+ # check for ncurses, fall back to curses
+ AC_CHECK_LIB([ncurses], [initscr],,AC_CHECK_LIB([curses], [initscr]))
++AC_SEARCH_LIBS([stdscr], [tinfo])
+
+ if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS="-Wall -fno-strict-aliasing"
diff --git a/x11-misc/xrestop/xrestop-0.4.ebuild b/x11-misc/xrestop/xrestop-0.4.ebuild
index 0dc5812339e7..bff634f4bb85 100644
--- a/x11-misc/xrestop/xrestop-0.4.ebuild
+++ b/x11-misc/xrestop/xrestop-0.4.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrestop/xrestop-0.4.ebuild,v 1.10 2007/05/30 16:58:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrestop/xrestop-0.4.ebuild,v 1.11 2014/11/19 09:54:39 jer Exp $
+
+EAPI=5
+inherit autotools eutils
DESCRIPTION="'Top' like statistics of X11 client's server side resource usage"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/xrestop"
@@ -9,15 +12,20 @@ SRC_URI="http://projects.o-hand.com/sources/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ppc sparc x86 ~x86-fbsd"
-IUSE=""
-RDEPEND="x11-libs/libXres
+RDEPEND="
x11-libs/libX11
- x11-libs/libXt"
-DEPEND="${RDEPEND}
- x11-proto/xproto"
+ x11-libs/libXres
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xproto
+"
-src_install () {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
}
+
+DOCS=( AUTHORS ChangeLog NEWS README )