summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-10-06 10:47:02 +0000
committerRémi Cardona <remi@gentoo.org>2009-10-06 10:47:02 +0000
commit6c706ede44968f0bb734677ee0cb80a69f524a66 (patch)
tree63d3862a97253b0dd27e6c967a18afd3f437a3ea /x11-misc/xkeyboard-config
parentBump to 0.1.15, fix homepage and src_uri (diff)
downloadgentoo-2-6c706ede44968f0bb734677ee0cb80a69f524a66.tar.gz
gentoo-2-6c706ede44968f0bb734677ee0cb80a69f524a66.tar.bz2
gentoo-2-6c706ede44968f0bb734677ee0cb80a69f524a66.zip
x11-misc/xkeyboard-config: bump to 1.7, sync with x11 overlay
(Portage version: 2.2_rc44/cvs/Linux i686)
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog7
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-1.7.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index e35916aefe6e..2f6a5c9d0536 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xkeyboard-config
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.72 2009/10/06 09:45:27 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.73 2009/10/06 10:47:02 remi Exp $
+
+*xkeyboard-config-1.7 (06 Oct 2009)
+
+ 06 Oct 2009; Rémi Cardona <remi@gentoo.org> +xkeyboard-config-1.7.ebuild:
+ bump to 1.7, sync with x11 overlay
06 Oct 2009; Rémi Cardona <remi@gentoo.org> -xkeyboard-config-1.1.ebuild:
drop old ebuilds
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-1.7.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-1.7.ebuild
new file mode 100644
index 000000000000..054b2d94001d
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-1.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-1.7.ebuild,v 1.1 2009/10/06 10:47:02 remi Exp $
+
+EAPI="2"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git"
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+else
+ SRC_URI="http://xlibs.freedesktop.org/xkbdesc/${P}.tar.bz2"
+fi
+
+inherit ${GIT_ECLASS} autotools
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="x11-apps/xkbcomp"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-perl/XML-Parser"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ intltoolize
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-xkb-base=/usr/share/X11/xkb \
+ --enable-compat-rules \
+ --disable-xkbcomp-symlink \
+ --with-xkb-rules-symlink=xorg \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ echo "CONFIG_PROTECT=\"/usr/share/X11/xkb\"" > "${T}"/10xkeyboard-config
+ doenvd "${T}"/10xkeyboard-config
+}