summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-12-25 22:28:55 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-12-25 22:28:55 +0000
commitd23205403b2911877c393879fdd73c17564b5343 (patch)
tree9f812a5d1e904eb6d46bfdcb4de69d7365c62b5a /x11-misc/xfe
parentStable for ia64, wrt bug #389839 (diff)
downloadgentoo-2-d23205403b2911877c393879fdd73c17564b5343.tar.gz
gentoo-2-d23205403b2911877c393879fdd73c17564b5343.tar.bz2
gentoo-2-d23205403b2911877c393879fdd73c17564b5343.zip
bump to EAPI=5, use l10n.eclass for LINGUAS handling, respect flags in debug mode, add missing dependencies, fix desktop file
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc/xfe')
-rw-r--r--x11-misc/xfe/ChangeLog9
-rw-r--r--x11-misc/xfe/files/xfe-1.33-desktopfile.patch14
-rw-r--r--x11-misc/xfe/files/xfe-1.33-flags.patch85
-rw-r--r--x11-misc/xfe/xfe-1.33-r1.ebuild75
4 files changed, 182 insertions, 1 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index 2ce48dccacac..e2cc0d1004e4 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xfe
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.81 2012/12/25 19:21:31 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.82 2012/12/25 22:28:55 hasufell Exp $
+
+*xfe-1.33-r1 (25 Dec 2012)
+
+ 25 Dec 2012; Julian Ospald <hasufell@gentoo.org> +xfe-1.33-r1.ebuild,
+ +files/xfe-1.33-desktopfile.patch, +files/xfe-1.33-flags.patch:
+ bump to EAPI=5, use l10n.eclass for LINGUAS handling, respect flags in debug
+ mode, add missing dependencies, fix desktop file
25 Dec 2012; Anthony G. Basile <blueness@gentoo.org> xfe-1.33.ebuild:
stable ppc, bug #448544, thanks peratu
diff --git a/x11-misc/xfe/files/xfe-1.33-desktopfile.patch b/x11-misc/xfe/files/xfe-1.33-desktopfile.patch
new file mode 100644
index 000000000000..e79a494adaf2
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-1.33-desktopfile.patch
@@ -0,0 +1,14 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Dec 25 18:01:35 UTC 2012
+Subject: fix desktop file
+
+--- xfe-1.33/xfp.desktop.in.in
++++ xfe-1.33/xfp.desktop.in.in
+@@ -6,7 +6,6 @@
+ Terminal=false
+ Type=Application
+ StartupNotify=@STARTUPNOTIFY@
+-MimeType=text/plain;
+ MimeType=application/x-deb;application/x-debian-package;application/x-rpm;
+ Icon=xfp
+ Categories=Utility;PackageManager;
diff --git a/x11-misc/xfe/files/xfe-1.33-flags.patch b/x11-misc/xfe/files/xfe-1.33-flags.patch
new file mode 100644
index 000000000000..ee5f2878d6b7
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-1.33-flags.patch
@@ -0,0 +1,85 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Dec 25 17:42:56 UTC 2012
+Subject: build system
+
+ add a "--enable-minimal-flags" option to
+ respect system flags
+
+--- xfe-1.33/configure.ac
++++ xfe-1.33/configure.ac
+@@ -5,7 +5,7 @@
+ # Initialize
+ AC_INIT([xfe], [1.33])
+ AC_CONFIG_SRCDIR([src/XFileExplorer.cpp])
+-AM_INIT_AUTOMAKE
++AM_INIT_AUTOMAKE([-Wall])
+ AM_CONFIG_HEADER([config.h])
+
+
+@@ -177,6 +177,10 @@
+ AC_ARG_ENABLE(debug,[ --enable-debug compile for debugging])
+ AC_MSG_RESULT([$enable_debug])
+
++# Add debug symbols
++AC_MSG_CHECKING(minimalflags)
++AC_ARG_ENABLE(minimalflags,[ --enable-minimalflags respect system flags as much as possible])
++AC_MSG_RESULT([$enable_minimalflags])
+
+ # Building for release
+ AC_MSG_CHECKING(for release build)
+@@ -184,29 +188,37 @@
+ AC_MSG_RESULT([$enable_release])
+
+
+-# Setting CXXFLAGS
+-if test "x$enable_debug" = "xyes" ; then
+- CXXFLAGS="${CXXFLAGS} -Wall -g -DDEBUG"
+-elif test "x$enable_release" = "xyes" ; then
+- CXXFLAGS="-DNDEBUG ${CXXFLAGS} "
+- if test "${GXX}" = "yes" ; then
+- CXXFLAGS="-O3 -Wuninitialized -ffast-math -fomit-frame-pointer -fno-strict-aliasing ${CXXFLAGS}"
++if test "x$enable_minimalflags" = "xyes" ; then
++ if test "x$enable_debug" = "xyes" ; then
++ CPPFLAGS="$CPPFLAGS -DDEBUG"
++ else
++ CPPFLAGS="$CPPFLAGS -DNDEBUG"
+ fi
+ else
+- CXXFLAGS="-O2 ${CXXFLAGS}"
+-fi
++ # Setting CXXFLAGS
++ if test "x$enable_debug" = "xyes" ; then
++ CXXFLAGS="${CXXFLAGS} -g -DDEBUG"
++ elif test "x$enable_release" = "xyes" ; then
++ CXXFLAGS="-DNDEBUG ${CXXFLAGS} "
++ if test "${GXX}" = "yes" ; then
++ CXXFLAGS="-O3 -Wuninitialized -ffast-math -fomit-frame-pointer -fno-strict-aliasing ${CXXFLAGS}"
++ fi
++ else
++ CXXFLAGS="-O2 ${CXXFLAGS}"
++ fi
+
+
+-# Setting CFLAGS
+-if test "x$enable_debug" = "xyes" ; then
+- CFLAGS="${CFLAGS} -Wall -g -DDEBUG"
+-elif test "x$enable_release" = "xyes" ; then
+- CFLAGS="-DNDEBUG ${CFLAGS}"
+- if test "${GCC}" = "yes" ; then
+- CFLAGS="-O3 -Wuninitialized -ffast-math -fomit-frame-pointer -fno-strict-aliasing ${CFLAGS}"
++ # Setting CFLAGS
++ if test "x$enable_debug" = "xyes" ; then
++ CFLAGS="${CFLAGS} -g -DDEBUG"
++ elif test "x$enable_release" = "xyes" ; then
++ CFLAGS="-DNDEBUG ${CFLAGS}"
++ if test "${GCC}" = "yes" ; then
++ CFLAGS="-O3 -Wuninitialized -ffast-math -fomit-frame-pointer -fno-strict-aliasing ${CFLAGS}"
++ fi
++ else
++ CFLAGS="-O2 ${CFLAGS}"
+ fi
+-else
+- CFLAGS="-O2 ${CFLAGS}"
+ fi
+
+
diff --git a/x11-misc/xfe/xfe-1.33-r1.ebuild b/x11-misc/xfe/xfe-1.33-r1.ebuild
new file mode 100644
index 000000000000..07d5e309aad1
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.33-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.33-r1.ebuild,v 1.1 2012/12/25 22:28:55 hasufell Exp $
+
+EAPI=5
+
+PLOCALES="
+ bs ca cs da de el es_AR es fr hu it ja nl no pl pt_BR pt_PT ru sv tr zh_CN
+ zh_TW
+"
+inherit autotools base l10n
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/fox:1.6[truetype,png]
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.32.2-missing_Xlib_h.patch
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-desktopfile.patch
+)
+
+src_prepare() {
+ base_src_prepare
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s/\s\s*/\n/g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ l10n_for_each_disabled_locale_do rm_locale
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-minimalflags \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ $(use_enable debug)
+}