summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-20 00:31:54 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-20 00:31:54 +0000
commita5b4ef9cf35f7bf75c42a30afa0130f6725d15af (patch)
treed6ab26bbd2c420d7386f75492119d6145dc6fc26 /x11-misc/x11vnc
parentVersion bump. (diff)
downloadgentoo-2-a5b4ef9cf35f7bf75c42a30afa0130f6725d15af.tar.gz
gentoo-2-a5b4ef9cf35f7bf75c42a30afa0130f6725d15af.tar.bz2
gentoo-2-a5b4ef9cf35f7bf75c42a30afa0130f6725d15af.zip
Version bump (bug #384407).
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/x11vnc')
-rw-r--r--x11-misc/x11vnc/ChangeLog8
-rw-r--r--x11-misc/x11vnc/files/x11vnc-0.9.13-warnings.patch42
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.13.ebuild74
3 files changed, 123 insertions, 1 deletions
diff --git a/x11-misc/x11vnc/ChangeLog b/x11-misc/x11vnc/ChangeLog
index a988c76a9a30..b960e057972f 100644
--- a/x11-misc/x11vnc/ChangeLog
+++ b/x11-misc/x11vnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/x11vnc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.95 2011/11/01 03:56:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.96 2011/11/20 00:31:54 radhermit Exp $
+
+*x11vnc-0.9.13 (20 Nov 2011)
+
+ 20 Nov 2011; Tim Harder <radhermit@gentoo.org> +x11vnc-0.9.13.ebuild,
+ +files/x11vnc-0.9.13-warnings.patch:
+ Version bump (bug #384407).
01 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> x11vnc-0.9.9.ebuild,
x11vnc-0.9.12.ebuild:
diff --git a/x11-misc/x11vnc/files/x11vnc-0.9.13-warnings.patch b/x11-misc/x11vnc/files/x11vnc-0.9.13-warnings.patch
new file mode 100644
index 000000000000..f80e83f196bc
--- /dev/null
+++ b/x11-misc/x11vnc/files/x11vnc-0.9.13-warnings.patch
@@ -0,0 +1,42 @@
+--- x11vnc-0.9.13.orig/x11vnc/remote.c
++++ x11vnc-0.9.13/x11vnc/remote.c
+@@ -5860,7 +5860,7 @@
+ }
+ if (!strcmp(p, "vncdisplay")) {
+ snprintf(buf, bufn, "aro=%s:%s", p,
+- NONUL(vnc_desktop_name));
++ vnc_desktop_name);
+ goto qry;
+ }
+ if (!strcmp(p, "icon_mode")) {
+@@ -6062,7 +6062,7 @@
+ if (!strcmp(p, "h") || !strcmp(p, "help") ||
+ !strcmp(p, "V") || !strcmp(p, "version") ||
+ !strcmp(p, "lastmod")) {
+- snprintf(buf, bufn, "aro=%s:%s", p, NONUL(lastmod));
++ snprintf(buf, bufn, "aro=%s:%s", p, lastmod);
+ goto qry;
+ }
+ if (!strcmp(p, "bg")) {
+--- x11vnc-0.9.13.orig/x11vnc/sslhelper.c
++++ x11vnc-0.9.13/x11vnc/sslhelper.c
+@@ -4041,7 +4041,7 @@
+ strncpy(last_get, rcookie, 100);
+ if (db) fprintf(stderr, "last_get: '%s'\n", last_get);
+ }
+- if (rcookie && strstr(rcookie, "VncViewer.class")) {
++ if (strstr(rcookie, "VncViewer.class")) {
+ rfbLog("\n");
+ rfbLog("helper[%d]:\n", pid);
+ rfbLog("***********************************************************\n");
+--- x11vnc-0.9.13.orig/x11vnc/userinput.c
++++ x11vnc-0.9.13/x11vnc/userinput.c
+@@ -1305,7 +1305,7 @@
+ int font_size = 15;
+ int win_y, scr_y, loc_cut = 4*font_size, y_cut = 10*font_size;
+
+- if (!xrecord_set_by_keys || !xrecord_name_info) {
++ if (!xrecord_set_by_keys) {
+ return 0;
+ }
+ if (xrecord_name_info[0] == '\0') {
diff --git a/x11-misc/x11vnc/x11vnc-0.9.13.ebuild b/x11-misc/x11vnc/x11vnc-0.9.13.ebuild
new file mode 100644
index 000000000000..4f35434e80e7
--- /dev/null
+++ b/x11-misc/x11vnc/x11vnc-0.9.13.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.13.ebuild,v 1.1 2011/11/20 00:31:54 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A VNC server for real X displays"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/"
+SRC_URI="mirror://sourceforge/libvncserver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="avahi crypt fbcon +jpeg ssl system-libvncserver threads tk xinerama +zlib"
+
+RDEPEND="system-libvncserver? ( >=net-libs/libvncserver-0.9.7[threads=,jpeg=,zlib=] )
+ !system-libvncserver? (
+ zlib? ( sys-libs/zlib )
+ jpeg? ( virtual/jpeg:0 )
+ )
+ ssl? ( dev-libs/openssl )
+ tk? ( dev-lang/tk )
+ avahi? ( >=net-dns/avahi-0.6.4 )
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ >=x11-libs/libXtst-1.1.0
+ x11-libs/libXdamage
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/inputproto
+ x11-proto/trapproto
+ x11-proto/recordproto
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+pkg_setup() {
+ if use avahi && ! use threads ; then
+ ewarn "Non-native avahi support has been enabled."
+ ewarn "Native avahi support can be enabled by also enabling the threads USE flag."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-warnings.patch
+}
+
+src_configure() {
+ # --without-v4l because of missing video4linux 2.x support wrt #389079
+ econf \
+ $(use_with system-libvncserver) \
+ $(use_with avahi) \
+ $(use_with xinerama) \
+ $(use_with ssl) \
+ $(use_with ssl crypto) \
+ $(use_with crypt) \
+ --without-v4l \
+ $(use_with jpeg) \
+ $(use_with zlib) \
+ $(use_with threads pthread) \
+ $(use_with fbcon fbdev)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc x11vnc/{ChangeLog,README}
+ # Remove include files, which conflict with net-libs/libvncserver
+ rm -rf "${D}"/usr/include
+}