summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-14 06:56:52 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-14 06:56:52 +0000
commitb5a8cacbc7eb8ef2b3912c197664ea9f58747c5d (patch)
treec040c02185864ee8a962befe653e40a293e3d67b /x11-misc/touchcal
parentsecurity bump - bug #363507 (diff)
downloadgentoo-2-b5a8cacbc7eb8ef2b3912c197664ea9f58747c5d.tar.gz
gentoo-2-b5a8cacbc7eb8ef2b3912c197664ea9f58747c5d.tar.bz2
gentoo-2-b5a8cacbc7eb8ef2b3912c197664ea9f58747c5d.zip
Fix for _FORTIFY_SOURCE indicates presence of overflow, #363543
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/touchcal')
-rw-r--r--x11-misc/touchcal/ChangeLog10
-rw-r--r--x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch16
-rw-r--r--x11-misc/touchcal/touchcal-0.31-r1.ebuild23
-rw-r--r--x11-misc/touchcal/touchcal-0.31.ebuild21
4 files changed, 60 insertions, 10 deletions
diff --git a/x11-misc/touchcal/ChangeLog b/x11-misc/touchcal/ChangeLog
index f525e356c063..b97146f658e7 100644
--- a/x11-misc/touchcal/ChangeLog
+++ b/x11-misc/touchcal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/touchcal
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/touchcal/ChangeLog,v 1.6 2008/12/04 21:25:44 dsd Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/touchcal/ChangeLog,v 1.7 2011/04/14 06:56:52 jlec Exp $
+
+*touchcal-0.31-r1 (14 Apr 2011)
+
+ 14 Apr 2011; Justin Lecher <jlec@gentoo.org> touchcal-0.31.ebuild,
+ +touchcal-0.31-r1.ebuild, +files/touchcal-0.31-buff-overflow.patch:
+ Fix for _FORTIFY_SOURCE indicates presence of overflow, #363543
04 Dec 2008; Daniel Drake <dsd@gentoo.org> metadata.xml:
Drop maintainership. I'll still help on bugs, but probably not on a timely
diff --git a/x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch b/x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch
new file mode 100644
index 000000000000..7c64d5c4c7ee
--- /dev/null
+++ b/x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch
@@ -0,0 +1,16 @@
+ touchcal.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/touchcal.c b/touchcal.c
+index 7341fd7..22bd978 100644
+--- a/touchcal.c
++++ b/touchcal.c
+@@ -96,7 +96,7 @@ static void init_mu(char dev[])
+ char buf[255],dummy[255];
+ char format_tablet[4],get_page[5],set_page[5],mode_stream[4];
+ char reset_controler[3],identify[4];
+- char data[16];
++ char data[26];
+
+ /*Open serial device for reading and writing*/
+ fd = open(dev, O_RDWR | O_NOCTTY );
diff --git a/x11-misc/touchcal/touchcal-0.31-r1.ebuild b/x11-misc/touchcal/touchcal-0.31-r1.ebuild
new file mode 100644
index 000000000000..ed32b1f2f163
--- /dev/null
+++ b/x11-misc/touchcal/touchcal-0.31-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/touchcal/touchcal-0.31-r1.ebuild,v 1.1 2011/04/14 06:56:52 jlec Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Touchscreen calibration utility"
+HOMEPAGE="http://touchcal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buff-overflow.patch
+}
diff --git a/x11-misc/touchcal/touchcal-0.31.ebuild b/x11-misc/touchcal/touchcal-0.31.ebuild
index ed80275da1cd..6687eda67ed3 100644
--- a/x11-misc/touchcal/touchcal-0.31.ebuild
+++ b/x11-misc/touchcal/touchcal-0.31.ebuild
@@ -1,18 +1,23 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/touchcal/touchcal-0.31.ebuild,v 1.5 2008/10/05 10:13:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/touchcal/touchcal-0.31.ebuild,v 1.6 2011/04/14 06:56:52 jlec Exp $
+
+EAPI="4"
+
+inherit eutils
DESCRIPTION="Touchscreen calibration utility"
-HOMEPAGE="http://touchcal.sourceforge.net"
+HOMEPAGE="http://touchcal.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~x86"
-DEPEND="sys-libs/ncurses"
IUSE=""
-src_install() {
- emake install DESTDIR="${D}" || die "failed to emake install"
- dodoc README ChangeLog
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buff-overflow.patch
}