summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-01-03 06:53:27 +0000
committerMichał Górny <mgorny@gentoo.org>2012-01-03 06:53:27 +0000
commitba1cf8cd40f3979cd8d32dc690feecc818d849ae (patch)
tree22dfcba693585c0f4b7bf73ab98400ea58aff808 /x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
parentVersion bump. The new version fixes timeout support. (diff)
downloadgentoo-2-ba1cf8cd40f3979cd8d32dc690feecc818d849ae.tar.gz
gentoo-2-ba1cf8cd40f3979cd8d32dc690feecc818d849ae.tar.bz2
gentoo-2-ba1cf8cd40f3979cd8d32dc690feecc818d849ae.zip
Version bump. The new version fixes timeout support.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild')
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild b/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
new file mode 100644
index 000000000000..f88ee0058fc2
--- /dev/null
+++ b/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild,v 1.1 2012/01/03 06:53:27 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+MY_PN=tinynotify-send
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A system-wide variant of tinynotify-send"
+HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
+SRC_URI="mirror://github/mgorny/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libtinynotify
+ ~x11-libs/libtinynotify-cli-${PV}
+ x11-libs/libtinynotify-systemwide"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( README )
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ myeconfargs=(
+ --disable-library
+ --disable-regular
+ --enable-system-wide
+ )
+
+ autotools-utils_src_configure
+}