summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-08-27 06:28:50 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-08-27 06:28:50 +0000
commit83fb82c2a2092578783ea046f38f06a4b5fc3228 (patch)
treed23f881d0e9d1581e5fce008bfcbf6b6cf976a1c /x11-misc/icecc/icecc-2.9.ebuild
parentremove cyrus-imap* for testing. (diff)
downloadgentoo-2-83fb82c2a2092578783ea046f38f06a4b5fc3228.tar.gz
gentoo-2-83fb82c2a2092578783ea046f38f06a4b5fc3228.tar.bz2
gentoo-2-83fb82c2a2092578783ea046f38f06a4b5fc3228.zip
*** empty log message ***
Diffstat (limited to 'x11-misc/icecc/icecc-2.9.ebuild')
-rw-r--r--x11-misc/icecc/icecc-2.9.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/icecc/icecc-2.9.ebuild b/x11-misc/icecc/icecc-2.9.ebuild
new file mode 100644
index 000000000000..6b9897c140f5
--- /dev/null
+++ b/x11-misc/icecc/icecc-2.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icecc/icecc-2.9.ebuild,v 1.1 2004/08/27 06:28:50 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="IceWM Control Center (only main program, see icewm-tools for the rest)"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://icecc.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+SLOT="0"
+
+DEPEND=">=x11-libs/qt-3.0.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s:/usr/local:/usr:" -i ${PN}.pro || die "sed failed"
+ echo >> ${PN}.pro -e "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}\nQMAKE_CFLAGS_RELEASE += ${CFLAGS}"
+}
+
+src_compile() {
+ qmake || die
+ emake || die
+}
+
+src_install() {
+ make INSTALL_ROOT="${D}" install || die
+
+ rm -rf ${D}/usr/doc
+ dohtml ${PN}/docs/en/*.{html,sgml}
+ dodoc AUTHORS ChangeLog README TODO
+ dodir /usr/share/${PN}/themes
+ cp -a theme/* ${D}/usr/share/${PN}/themes/
+ chmod go-w ${D}/usr/share/${PN}/themes/
+}
+
+pkg_postinst() {
+ einfo "emerge icewm-tools for the control center helper tools"
+}