summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-02-05 10:10:32 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-02-05 10:10:32 +0000
commitf073935aadf5faf266ddb4ff6be7e4a37cd28f06 (patch)
tree7741dc0b471fbad6b5a7c24fca40eddfac416744 /x11-misc/hotkeys
parentMinor ebuild cleanups. (diff)
downloadgentoo-2-f073935aadf5faf266ddb4ff6be7e4a37cd28f06.tar.gz
gentoo-2-f073935aadf5faf266ddb4ff6be7e4a37cd28f06.tar.bz2
gentoo-2-f073935aadf5faf266ddb4ff6be7e4a37cd28f06.zip
Version bump
Diffstat (limited to 'x11-misc/hotkeys')
-rw-r--r--x11-misc/hotkeys/ChangeLog7
-rw-r--r--x11-misc/hotkeys/files/digest-hotkeys-0.5.7.11
-rw-r--r--x11-misc/hotkeys/files/hotkeys-0.5.7.1-gentoo.diff24
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.7.1.ebuild41
4 files changed, 72 insertions, 1 deletions
diff --git a/x11-misc/hotkeys/ChangeLog b/x11-misc/hotkeys/ChangeLog
index 3a19d19a404f..6fb01b0f4ac0 100644
--- a/x11-misc/hotkeys/ChangeLog
+++ b/x11-misc/hotkeys/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/hotkeys
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.8 2002/12/15 00:56:44 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.9 2003/02/05 10:10:32 aliz Exp $
+
+*hotkeys-0.5.7.1.ebuild (05 Feb 2003)
+
+ 05 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump, closes #13821.
*hotkeys-0.5.5.ebuild (11 Sep 2002)
diff --git a/x11-misc/hotkeys/files/digest-hotkeys-0.5.7.1 b/x11-misc/hotkeys/files/digest-hotkeys-0.5.7.1
new file mode 100644
index 000000000000..9c3c845c6e2c
--- /dev/null
+++ b/x11-misc/hotkeys/files/digest-hotkeys-0.5.7.1
@@ -0,0 +1 @@
+MD5 68e2aea6b4444f943b5f85ac00542a1c hotkeys_0.5.7.1.tar.gz 234289
diff --git a/x11-misc/hotkeys/files/hotkeys-0.5.7.1-gentoo.diff b/x11-misc/hotkeys/files/hotkeys-0.5.7.1-gentoo.diff
new file mode 100644
index 000000000000..83b8a88dce7a
--- /dev/null
+++ b/x11-misc/hotkeys/files/hotkeys-0.5.7.1-gentoo.diff
@@ -0,0 +1,24 @@
+--- ./src/kbddef.c.xml2 Sun Jun 2 22:37:33 2002
++++ ./src/kbddef.c Sun Jun 2 22:37:43 2002
+@@ -38,7 +38,7 @@
+ #include "XF86keysym.h"
+
+ #include <xmlmemory.h>
+-#include <parser.h>
++#include <libxml2/libxml/parser.h>
+
+ #include "hotkeys.h"
+ #include "kbddef.h"
+
+--- /tmp/kbddef.c Wed Sep 11 18:51:19 2002
++++ src/kbddef.c Wed Sep 11 18:51:33 2002
+@@ -37,7 +37,7 @@
+ */
+ #include "XF86keysym.h"
+
+-#include <xmlmemory.h>
++#include <libxml2/libxml/xmlmemory.h>
+ #include <libxml2/libxml/parser.h>
+
+ #include "hotkeys.h"
+
diff --git a/x11-misc/hotkeys/hotkeys-0.5.7.1.ebuild b/x11-misc/hotkeys/hotkeys-0.5.7.1.ebuild
new file mode 100644
index 000000000000..48b2456111e8
--- /dev/null
+++ b/x11-misc/hotkeys/hotkeys-0.5.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1.ebuild,v 1.1 2003/02/05 10:10:32 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Make use of extra buttons on newer keyboards."
+SRC_URI="http://ypwong.org/hotkeys/${PV}/${PN}_${PV}.tar.gz"
+HOMEPAGE="http://ypwong.org/hotkeys/"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/x11
+ >=dev-libs/libxml2-2.2.8
+ >=sys-libs/db-3.2.9
+ >=x11-libs/xosd-1.0.0
+ gtk2? ( >=x11-libs/gtk+-2.0.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf="--with-xosd"
+
+ use gtk2 \
+ && myconf="${myconf} --with-gtk"
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog COPYING README TODO
+}