summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-25 07:21:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-25 07:21:40 +0000
commit7edbb8f84e9bd3d364a4ef8a94d44f361a416d28 (patch)
treecf0dc09041b27d517ade08d50886e640484f575b /x11-misc/gmrun
parentold (diff)
downloadgentoo-2-7edbb8f84e9bd3d364a4ef8a94d44f361a416d28.tar.gz
gentoo-2-7edbb8f84e9bd3d364a4ef8a94d44f361a416d28.tar.bz2
gentoo-2-7edbb8f84e9bd3d364a4ef8a94d44f361a416d28.zip
Fix building with glibc-2.10+ wrt #273731, thanks to Semen Maryasin.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/gmrun')
-rw-r--r--x11-misc/gmrun/ChangeLog8
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch11
-rw-r--r--x11-misc/gmrun/gmrun-0.9.2.ebuild25
3 files changed, 27 insertions, 17 deletions
diff --git a/x11-misc/gmrun/ChangeLog b/x11-misc/gmrun/ChangeLog
index b19d419102d4..574d0a5164ca 100644
--- a/x11-misc/gmrun/ChangeLog
+++ b/x11-misc/gmrun/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/gmrun
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/ChangeLog,v 1.17 2008/12/23 23:51:47 tcunha Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/ChangeLog,v 1.18 2009/07/25 07:21:40 ssuominen Exp $
+
+ 25 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> gmrun-0.9.2.ebuild,
+ +files/gmrun-0.9.2-glibc210.patch:
+ Fix building with glibc-2.10+ wrt #273731, thanks to Semen Maryasin.
23 Dec 2008; Tiago Cunha <tcunha@gentoo.org> gmrun-0.9.2.ebuild:
stable sparc
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch b/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch
new file mode 100644
index 000000000000..989183b2be46
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch
@@ -0,0 +1,11 @@
+--- gmrun-0.9.2/src/gtkcompletionline.cc.orig 2009-06-19 22:38:14.000000000 +0400
++++ gmrun-0.9.2/src/gtkcompletionline.cc 2009-06-19 22:37:14.000000000 +0400
+@@ -376,7 +377,7 @@
+ return 0;
+ }
+
+-int my_alphasort(const void* va, const void* vb) {
++int my_alphasort(const dirent** va, const dirent** vb) {
+ const struct dirent** a = (const struct dirent**)va;
+ const struct dirent** b = (const struct dirent**)vb;
+
diff --git a/x11-misc/gmrun/gmrun-0.9.2.ebuild b/x11-misc/gmrun/gmrun-0.9.2.ebuild
index 301222ad2c85..5cdf38f344a9 100644
--- a/x11-misc/gmrun/gmrun-0.9.2.ebuild
+++ b/x11-misc/gmrun/gmrun-0.9.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/gmrun-0.9.2.ebuild,v 1.15 2008/12/23 23:51:47 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/gmrun-0.9.2.ebuild,v 1.16 2009/07/25 07:21:40 ssuominen Exp $
+EAPI=2
inherit autotools eutils
DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
@@ -13,15 +14,15 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.2.0
+RDEPEND="x11-libs/gtk+:2
dev-libs/popt"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ sys-apps/sed"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-glibc210.patch
# Disable check for STLport due to bug #164339
sed -i -e 's,^AC_PATH_STLPORT,dnl REMOVED ,g' configure.in
sed -i -e 's,@STLPORT_[A-Z]\+@,,g' src/Makefile.am
@@ -29,12 +30,6 @@ src_unpack() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README NEWS
}
-
-pkg_postinst(){
- einfo
- einfo "Gmrun now featers a ~/.gmrunrc see /usr/share/gmrun/gmrunrc for help"
- einfo
-}