summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2007-07-07 09:15:48 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2007-07-07 09:15:48 +0000
commitdc895621747754494c950740b790625c16ee6eda (patch)
tree3e93e6f7d6601d542c91fd75d283c4783373ad3b /x11-misc/alock/alock-60-r3.ebuild
parentVersion bump for bug #182653. (diff)
downloadgentoo-2-dc895621747754494c950740b790625c16ee6eda.tar.gz
gentoo-2-dc895621747754494c950740b790625c16ee6eda.tar.bz2
gentoo-2-dc895621747754494c950740b790625c16ee6eda.zip
Install manpages to the right place, bug #184252. Patch by Tiago Cunha.
(Portage version: 2.1.2.9)
Diffstat (limited to 'x11-misc/alock/alock-60-r3.ebuild')
-rw-r--r--x11-misc/alock/alock-60-r3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/alock/alock-60-r3.ebuild b/x11-misc/alock/alock-60-r3.ebuild
new file mode 100644
index 000000000000..1c66083cb8c5
--- /dev/null
+++ b/x11-misc/alock/alock-60-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alock/alock-60-r3.ebuild,v 1.1 2007/07/07 09:15:48 hansmi Exp $
+
+DESCRIPTION="alock - locks the local X display until a password is entered"
+HOMEPAGE="
+ http://code.google.com/p/alock/
+ http://darkshed.net/projects/alock
+"
+SRC_URI="http://alock.googlecode.com/files/alock-svn-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ media-libs/imlib2
+"
+RDEPEND=""
+
+MY_S="${WORKDIR}/alock-svn-${PV}"
+
+src_unpack() {
+ unpack "${A}"
+ sed -i 's|\$(DESTDIR)\$(prefix)/man|\$(DESTDIR)\$(prefix)/share/man|g' \
+ "${MY_S}"/Makefile || die "sed failed"
+}
+
+src_compile() {
+ cd "${MY_S}" || die
+
+ econf --with-all || die
+ emake || die
+}
+
+src_install() {
+ cd "${MY_S}" || die
+
+ dobin src/alock
+ doman alock.1
+ dodoc README.txt LICENSE.txt CHANGELOG.txt
+
+ insinto /usr/share/alock/xcursors
+ doins contrib/xcursor-*
+
+ insinto /usr/share/alock/bitmaps
+ doins bitmaps/*
+}