summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-20 17:25:23 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-20 17:25:23 +0000
commitbc7beaa522a3533703c7a035711db39cb7b36e41 (patch)
treec4b70a2df1ccbcfae3400be8ce9d8f973f76fa08 /x11-libs
parentversion bump to 0.11 (diff)
downloadgentoo-2-bc7beaa522a3533703c7a035711db39cb7b36e41.tar.gz
gentoo-2-bc7beaa522a3533703c7a035711db39cb7b36e41.tar.bz2
gentoo-2-bc7beaa522a3533703c7a035711db39cb7b36e41.zip
Add qwebview to build/install
(Portage version: 2.1.3.16)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.4.0_rc1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/qt-webkit-4.4.0_rc1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.4.0_rc1.ebuild
index b22298ed1486..b6b6b72a5caa 100644
--- a/x11-libs/qt-webkit/qt-webkit-4.4.0_rc1.ebuild
+++ b/x11-libs/qt-webkit/qt-webkit-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.0_rc1.ebuild,v 1.2 2007/12/20 16:07:59 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.0_rc1.ebuild,v 1.3 2007/12/20 17:25:23 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -94,12 +94,18 @@ src_compile() {
cd "${S}"/src/3rdparty/webkit/WebCore
qmake "LIBS+=-L${QTLIBDIR}" && emake || die
+
+ cd "${S}"/tools/designer/src/plugins/qwebview
+ qmake "LIBS+=-L${QTLIBDIR}" && emake || die
}
src_install() {
cd "${S}"/src/3rdparty/webkit/WebCore
emake INSTALL_ROOT="${D}" install || die
+ cd "${S}"/tools/designer/src/plugins/qwebview
+ emake INSTALL_ROOT="${D}" install || die
+
sed -i -e "s:${S}/lib:${QTLIBDIR}:g" "${D}"/${QTLIBDIR}/*.la
sed -i -e "s:${S}/lib:${QTLIBDIR}:g" "${D}"/${QTLIBDIR}/*.prl
sed -i -e "s:${S}/lib:${QTLIBDIR}:g" "${D}"/${QTLIBDIR}/pkgconfig/*.pc