summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-12-06 12:34:48 +0000
committerHanno Böck <hanno@gentoo.org>2005-12-06 12:34:48 +0000
commit3f16dc2b1a91e29446ace7308c0ab65bb58fac5e (patch)
tree7913f141ce4d3e6f318bae30f0ecad613a78eff6 /x11-libs/wxGTK
parent- initial multilib profile (diff)
downloadgentoo-2-3f16dc2b1a91e29446ace7308c0ab65bb58fac5e.tar.gz
gentoo-2-3f16dc2b1a91e29446ace7308c0ab65bb58fac5e.tar.bz2
gentoo-2-3f16dc2b1a91e29446ace7308c0ab65bb58fac5e.zip
wxGTK gcc41 fix
(Portage version: 2.0.53)
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/ChangeLog6
-rw-r--r--x11-libs/wxGTK/files/wxWidgets-2.6.2-gcc41.patch13
-rw-r--r--x11-libs/wxGTK/wxGTK-2.6.2-r1.ebuild9
3 files changed, 23 insertions, 5 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index b6ef53e1ffdf..8c5bd92b6b1d 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.97 2005/11/26 20:02:59 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.98 2005/12/06 12:34:48 hanno Exp $
+
+ 06 Dec 2005; Hanno Boeck <hanno@gentoo.org>
+ +files/wxWidgets-2.6.2-gcc41.patch, wxGTK-2.6.2-r1.ebuild:
+ Fix for gcc 4.1.
26 Nov 2005; Karol Wojtaszek <sekretarz@gentoo.org>
+files/wxGTK-2.4.2-pango_fix.patch, +wxGTK-2.4.2-r4.ebuild:
diff --git a/x11-libs/wxGTK/files/wxWidgets-2.6.2-gcc41.patch b/x11-libs/wxGTK/files/wxWidgets-2.6.2-gcc41.patch
new file mode 100644
index 000000000000..675ea8f5ebb6
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxWidgets-2.6.2-gcc41.patch
@@ -0,0 +1,13 @@
+--- wxWidgets-2.6.2/src/common/uri.cpp 2005-08-13 02:24:13.000000000 +0200
++++ wxWidgets-2.6.2-gcc41/src/common/uri.cpp 2005-12-04 22:49:30.996859750 +0100
+@@ -886,8 +886,8 @@
+ op += 3;
+ }
+
+- m_path = base.m_path.substr(0, bp - base.m_path.c_str()) +
+- m_path.substr((op - m_path.c_str()), m_path.Length());
++ m_path = (wxString)base.m_path.substr(0, bp - base.m_path.c_str()) +
++ (wxString)m_path.substr((op - m_path.c_str()), m_path.Length());
+ }
+ }
+
diff --git a/x11-libs/wxGTK/wxGTK-2.6.2-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.6.2-r1.ebuild
index 33ae6c96758c..88b32145d124 100644
--- a/x11-libs/wxGTK/wxGTK-2.6.2-r1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.2-r1.ebuild,v 1.1 2005/11/26 17:32:08 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.2-r1.ebuild,v 1.2 2005/12/06 12:34:48 hanno Exp $
inherit wxlib gnuconfig
@@ -28,10 +28,11 @@ pkg_setup() {
}
src_unpack() {
- unpack ${A}
- cd ${S}
+ unpack ${A}
+ cd ${S}
- epatch ${FILESDIR}/intl.cpp.diff
+ epatch ${FILESDIR}/wxWidgets-2.6.2-gcc41.patch
+ epatch ${FILESDIR}/intl.cpp.diff
}
src_compile() {