summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 16:39:03 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 16:39:03 +0000
commit6d1f2f367d0e2dcf0d6603da38283da511a225bc (patch)
tree69dadb38bfd4d2a64e01b19c7f44c572a748582b /x11-libs/qt-svg
parenttypo (diff)
downloadgentoo-2-6d1f2f367d0e2dcf0d6603da38283da511a225bc.tar.gz
gentoo-2-6d1f2f367d0e2dcf0d6603da38283da511a225bc.tar.bz2
gentoo-2-6d1f2f367d0e2dcf0d6603da38283da511a225bc.zip
Version bump
(Portage version: 2.2_rc85/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-svg')
-rw-r--r--x11-libs/qt-svg/ChangeLog8
-rw-r--r--x11-libs/qt-svg/qt-svg-4.7.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index 3be5ba781951..889fe6faa8b8 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.70 2010/09/13 21:23:06 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.71 2010/09/21 16:39:03 tampakrap Exp $
+
+*qt-svg-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-svg-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> qt-svg-4.6.2.ebuild:
Stable on alpha, bug #297299
diff --git a/x11-libs/qt-svg/qt-svg-4.7.0.ebuild b/x11-libs/qt-svg/qt-svg-4.7.0.ebuild
new file mode 100644
index 000000000000..43f4eb50f4e3
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.7.0.ebuild,v 1.1 2010/09/21 16:39:03 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/svg
+ src/plugins/imageformats/svg
+ src/plugins/iconengines/svgiconengine"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtSvg/
+ include/Qt/
+ include/QtGui/
+ include/QtCore/
+ include/QtXml/
+ src/corelib/
+ src/gui/
+ src/plugins/
+ src/xml
+ src/3rdparty"
+
+ QCONFIG_ADD="svg"
+ QCONFIG_DEFINE="QT_SVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -svg -no-xkb -no-fontconfig -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-gtkstyle
+ -v -continue"
+ qt4-build_src_configure
+}