summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-19 16:31:42 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-19 16:31:42 +0000
commitdc19f3ed51dc4a1e23d89d189ecbc01f486d0a6f (patch)
treebb7fa10dcdc39cc711700b1d14620e541cc13703 /x11-libs/qt-assistant
parentRevert making the CONFIG_DEVTMPFS check fatal. (diff)
downloadgentoo-2-dc19f3ed51dc4a1e23d89d189ecbc01f486d0a6f.tar.gz
gentoo-2-dc19f3ed51dc4a1e23d89d189ecbc01f486d0a6f.tar.bz2
gentoo-2-dc19f3ed51dc4a1e23d89d189ecbc01f486d0a6f.zip
Don't use the icon absolute path in desktop file (bug 403129). General ebuild cleanup.
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog9
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild (renamed from x11-libs/qt-assistant/qt-assistant-4.8.0.ebuild)102
2 files changed, 48 insertions, 63 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 3a44cb5194a7..bf9a21102d2a 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.121 2012/02/10 00:57:22 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.122 2012/03/19 16:31:42 pesa Exp $
+
+*qt-assistant-4.8.0-r1 (19 Mar 2012)
+
+ 19 Mar 2012; Davide Pesavento <pesa@gentoo.org> +qt-assistant-4.8.0-r1.ebuild,
+ -qt-assistant-4.8.0.ebuild:
+ Don't use the icon absolute path in desktop file (bug 403129). General ebuild
+ cleanup.
10 Feb 2012; Davide Pesavento <pesa@gentoo.org> qt-assistant-4.6.2-r2.ebuild,
qt-assistant-4.6.2.ebuild, qt-assistant-4.6.3.ebuild:
diff --git a/x11-libs/qt-assistant/qt-assistant-4.8.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild
index 583e631b6ef7..35df3844613b 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.8.0.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild
@@ -1,22 +1,17 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.8.0.ebuild,v 1.2 2012/02/10 00:51:18 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild,v 1.1 2012/03/19 16:31:42 pesa Exp $
EAPI="3"
-if [[ ${PV} == 4*9999 ]]; then
- ECLASS="-edge"
-fi
-inherit qt4-build${ECLASS}
-DESCRIPTION="The assistant help module for the Qt toolkit"
+inherit qt4-build
+
+DESCRIPTION="The Help module and Assistant application for the Qt toolkit"
+SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
SLOT="4"
-if [[ ${PV} != 4*9999 ]]; then
- KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos"
-else
- KEYWORDS=""
-fi
+
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos"
IUSE="compat doc +glib qt3support trace webkit"
-SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
DEPEND="~x11-libs/qt-gui-${PV}[aqua=,c++0x=,qpa=,debug=,glib=,qt3support=,trace?]
~x11-libs/qt-sql-${PV}[aqua=,c++0x=,qpa=,debug=,qt3support=,sqlite]
@@ -30,31 +25,29 @@ PATCHES=(
pkg_setup() {
# Pixeltool isn't really assistant related, but it relies on
- # the assistant libraries. doc/qch/
+ # the assistant libraries.
QT4_TARGET_DIRECTORIES="
tools/assistant
tools/pixeltool
tools/qdoc3"
- if [[ ${PV} != 4*9999 ]]; then
- QT4_EXTRACT_DIRECTORIES="
- tools/
- demos/
- examples/
- src/
- include/
- doc/"
- fi
+ QT4_EXTRACT_DIRECTORIES="
+ tools
+ demos
+ examples
+ src
+ include
+ doc"
+
+ use trace && QT4_TARGET_DIRECTORIES+=" tools/qttracereplay"
- use trace && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- tools/qttracereplay"
QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
${QT4_EXTRACT_DIRECTORIES}"
- qt4-build${ECLASS}_pkg_setup
+ qt4-build_pkg_setup
}
src_unpack() {
- qt4-build${ECLASS}_src_unpack
+ qt4-build_src_unpack
# compat version
# http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
if use compat; then
@@ -68,7 +61,7 @@ src_unpack() {
}
src_prepare() {
- qt4-build${ECLASS}_src_prepare
+ qt4-build_src_prepare
use compat && epatch "${FILESDIR}"/${PN}-4.7-fix-compat.patch
@@ -80,16 +73,17 @@ src_prepare() {
}
src_configure() {
- myconf="${myconf} -no-xkb -no-fontconfig -no-xrandr
+ myconf+="
+ -no-xkb -no-fontconfig -no-xrandr
-no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
-no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
-no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
-no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
-no-fontconfig -no-multimedia -no-svg
$(qt_use qt3support) $(qt_use webkit)"
- ! use glib && myconf="${myconf} -no-glib"
+ use glib || myconf+=" -no-glib"
- qt4-build${ECLASS}_src_configure
+ qt4-build_src_configure
}
src_compile() {
@@ -97,51 +91,35 @@ src_compile() {
export LD_LIBRARY_PATH="${S}/lib:${QTLIBDIR}"
export DYLD_LIBRARY_PATH="${S}/lib:${S}/lib/QtHelp.framework"
- qt4-build${ECLASS}_src_compile
+ qt4-build_src_compile
- # ugly hack to build docs
cd "${S}"
+ # ugly hack to build docs
qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
- # live ebuild cannot build qch_docs. It will build them through emake docs
- if [[ ${PV} != 4*9999 ]]; then
- emake qch_docs || die "emake qch_docs failed "
- fi
+ emake qch_docs || die "emake qch_docs failed"
+
if use doc; then
emake docs || die "emake docs failed"
fi
- qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
}
src_install() {
- qt4-build${ECLASS}_src_install
+ qt4-build_src_install
+
cd "${S}"
- #see src_compile note
- if [[ ${PV} != 4*9999 ]]; then
- emake INSTALL_ROOT="${D}" install_qchdocs \
- || die "failed to install qch docs"
- fi
+ emake INSTALL_ROOT="${D}" install_qchdocs || die "failed to install qch docs"
+
if use doc; then
- emake INSTALL_ROOT="${D}" install_htmldocs \
- || die "failed to install htmldocs"
- # Now it is time for the live ebuild to install the qch docs
- if [[ ${PV} == 4*9999 ]]; then
- emake INSTALL_ROOT="${D}" install_qchdocs \
- || die "failed to install qch docs"
- fi
+ emake INSTALL_ROOT="${D}" install_htmldocs || die "failed to install html docs"
fi
- dobin "${S}"/bin/qdoc3 || die "Failed to install qdoc3"
- # install correct assistant icon, bug 241208
- dodir /usr/share/pixmaps/ || die "dodir failed"
- insinto /usr/share/pixmaps/
- doins tools/assistant/tools/assistant/images/assistant.png ||
- die "doins failed"
- # Note: absolute image path required here!
- make_desktop_entry assistant Assistant \
- "${EPREFIX}"/usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' \
- || die "make_desktop_entry failed"
+
+ dobin "${S}"/bin/qdoc3 || die
+
+ doicon tools/assistant/tools/assistant/images/assistant.png || die
+ make_desktop_entry assistant Assistant assistant 'Qt;Development'
if use compat; then
- insinto /usr/share/qt4/mkspecs/features || die "insinto failed"
- doins tools/assistant/compat/features/assistant.prf || die "doins failed"
+ insinto /usr/share/qt4/mkspecs/features
+ doins tools/assistant/compat/features/assistant.prf || die
fi
}