summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-10-09 20:26:39 +0000
committerAlex Alexander <wired@gentoo.org>2010-10-09 20:26:39 +0000
commitbc8791be889d00a274ce623a058d2f5dc0315c7f (patch)
treece68d4edb42e624af0a049c0006d182686e29547 /x11-libs/qt-assistant
parentStable on amd64 wrt bug #339475 (diff)
downloadgentoo-2-bc8791be889d00a274ce623a058d2f5dc0315c7f.tar.gz
gentoo-2-bc8791be889d00a274ce623a058d2f5dc0315c7f.tar.bz2
gentoo-2-bc8791be889d00a274ce623a058d2f5dc0315c7f.zip
added optional compatibility package support
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog7
-rw-r--r--x11-libs/qt-assistant/files/qt-assistant-4.7-fix-compat.patch123
-rw-r--r--x11-libs/qt-assistant/files/qt-assistant-4.7-include.tar.gzbin0 -> 448 bytes
-rw-r--r--x11-libs/qt-assistant/metadata.xml3
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild31
5 files changed, 161 insertions, 3 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 1c3bce5aeb88..0e9d82fb48f8 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.89 2010/10/09 16:50:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.90 2010/10/09 20:26:38 wired Exp $
+
+ 09 Oct 2010; Alex Alexander <wired@gentoo.org> qt-assistant-4.7.0.ebuild,
+ +files/qt-assistant-4.7-fix-compat.patch,
+ +files/qt-assistant-4.7-include.tar.gz, metadata.xml:
+ added optional compatibility package support
09 Oct 2010; Raúl Porcel <armin76@gentoo.org> qt-assistant-4.7.0.ebuild:
Add ~ia64 wrt #338289
diff --git a/x11-libs/qt-assistant/files/qt-assistant-4.7-fix-compat.patch b/x11-libs/qt-assistant/files/qt-assistant-4.7-fix-compat.patch
new file mode 100644
index 000000000000..1c28c151cfbd
--- /dev/null
+++ b/x11-libs/qt-assistant/files/qt-assistant-4.7-fix-compat.patch
@@ -0,0 +1,123 @@
+--- tools/assistant/compat/compat.pro 2010-10-08 16:54:09.804000000 +0300
++++ tools/assistant/compat/compat.pro 2010-10-08 16:54:37.884000000 +0300
+@@ -14,6 +14,8 @@
+
+ PROJECTNAME = Assistant
+
++DESTDIR = ../../../bin
++
+ FORMS += helpdialog.ui \
+ mainwindow.ui \
+ tabbedbrowser.ui \
+@@ -59,6 +61,9 @@
+ TARGET = Assistant_adp
+ }
+
++target.path=$$[QT_INSTALL_BINS]
++INSTALLS += target
++
+ TRANSLATIONS = translations/assistant_adp_de.ts \
+ translations/assistant_adp_ja.ts \
+ translations/assistant_adp_pl.ts \
+--- tools/assistant/assistant.pro 2010-09-10 12:04:47.000000000 +0300
++++ tools/assistant/assistant.pro 2010-06-02 05:03:09.000000000 +0300
+@@ -3,4 +3,6 @@
+
+ SUBDIRS += lib/fulltextsearch \
+ lib \
+- tools
++ tools \
++ compat \
++ compat/lib \
+\ No newline at end of file
+--- /dev/null
++++ tools/assistant/compat/lib/QtAssistant/qassistantclient_global.h
+@@ -0,0 +1 @@
++#include "../qassistantclient_global.h"
+--- /dev/null 2010-09-28 21:07:22.854999850 +0300
++++ tools/assistant/compat/assistant.pro 2010-06-02 05:03:09.000000000 +0300
+@@ -0,0 +1,84 @@
++include($$QT_SOURCE_TREE/tools/shared/fontpanel/fontpanel.pri)
++
++TEMPLATE = app
++LANGUAGE = C++
++TARGET = assistant_adp
++
++CONFIG += qt warn_on
++
++unix:contains(QT_CONFIG, dbus):QT += dbus
++
++build_all:!build_pass {
++ CONFIG -= build_all
++ CONFIG += release
++}
++QT += xml network
++
++PROJECTNAME = Assistant
++DESTDIR = ../../../bin
++
++FORMS += helpdialog.ui \
++ mainwindow.ui \
++ tabbedbrowser.ui \
++ topicchooser.ui
++
++SOURCES += main.cpp \
++ helpwindow.cpp \
++ topicchooser.cpp \
++ docuparser.cpp \
++ index.cpp \
++ profile.cpp \
++ config.cpp \
++ helpdialog.cpp \
++ mainwindow.cpp \
++ tabbedbrowser.cpp \
++ fontsettingsdialog.cpp
++
++HEADERS += helpwindow.h \
++ topicchooser.h \
++ docuparser.h \
++ index.h \
++ profile.h \
++ helpdialog.h \
++ mainwindow.h \
++ tabbedbrowser.h \
++ config.h \
++ fontsettingsdialog.h
++
++RESOURCES += assistant.qrc
++
++contains(QT_PRODUCT, OpenSource.*):DEFINES *= QT_OPENSOURCE
++DEFINES += QT_KEYWORDS
++#DEFINES += QT_PALMTOPCENTER_DOCS
++
++win32 {
++ !wince*:LIBS += -lshell32
++ RC_FILE = assistant.rc
++}
++
++mac {
++ ICON = assistant.icns
++ TARGET = Assistant_adp
++ QMAKE_INFO_PLIST = Info_mac.plist
++}
++
++target.path=$$[QT_INSTALL_BINS]
++INSTALLS += target
++
++TRANSLATIONS = assistant_de.ts
++
++unix:!contains(QT_CONFIG, zlib):LIBS += -lz
++
++contains(CONFIG, static): {
++ win32 {
++ exists($$[QT_INSTALL_PLUGINS]/imageformats/qjpeg.lib) {
++ QTPLUGIN += qjpeg
++ DEFINES += USE_STATIC_JPEG_PLUGIN
++ }
++ } else {
++ exists($$[QT_INSTALL_PLUGINS]/imageformats/qjpeg.a) {
++ QTPLUGIN += qjpeg
++ DEFINES += USE_STATIC_JPEG_PLUGIN
++ }
++ }
++}
diff --git a/x11-libs/qt-assistant/files/qt-assistant-4.7-include.tar.gz b/x11-libs/qt-assistant/files/qt-assistant-4.7-include.tar.gz
new file mode 100644
index 000000000000..34207d7051e8
--- /dev/null
+++ b/x11-libs/qt-assistant/files/qt-assistant-4.7-include.tar.gz
Binary files differ
diff --git a/x11-libs/qt-assistant/metadata.xml b/x11-libs/qt-assistant/metadata.xml
index 6bde1b8bb16d..22504192ebcd 100644
--- a/x11-libs/qt-assistant/metadata.xml
+++ b/x11-libs/qt-assistant/metadata.xml
@@ -3,6 +3,9 @@
<pkgmetadata>
<herd>qt</herd>
<use>
+ <flag name='compat'>Build the extra compatibility package required by
+ a few packages. More information at
+ http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/</flag>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
<flag name='trace'>Build the qttracereplay utility which is required to
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
index 3418ac9384d6..0924800d524c 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.4 2010/10/09 16:50:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.5 2010/10/09 20:26:38 wired Exp $
EAPI="3"
inherit qt4-build
@@ -8,7 +8,8 @@ inherit qt4-build
DESCRIPTION="The assistant help module for the Qt toolkit"
SLOT="4"
KEYWORDS="~amd64 ~arm ~ia64 ~x86"
-IUSE="doc +glib trace"
+IUSE="compat doc +glib trace"
+SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
DEPEND="~x11-libs/qt-gui-${PV}[aqua=,glib=,trace?]
~x11-libs/qt-sql-${PV}[aqua=,sqlite]
@@ -38,6 +39,27 @@ pkg_setup() {
qt4-build_pkg_setup
}
+src_unpack() {
+ qt4-build_src_unpack
+ # compat version
+ # http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
+ if use compat; then
+ unpack "${PN}"-qassistantclient-library-compat-src-4.6.3.tar.gz
+ mv "${WORKDIR}"/"${PN}"-qassistantclient-library-compat-version-4.6.3 \
+ "${S}"/tools/assistant/compat ||
+ die "moving compat to the right place failed"
+ tar xzf "${FILESDIR}"/"${PN}"-4.7-include.tar.gz -C "${S}"/include/ ||
+ die "unpacking the include files failed"
+ fi
+}
+
+src_prepare() {
+ qt4-build_src_prepare
+ if use compat; then
+ epatch "${FILESDIR}"/"${PN}"-4.7-fix-compat.patch
+ fi
+}
+
src_configure() {
myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
-no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
@@ -85,4 +107,9 @@ src_install() {
make_desktop_entry "${EPREFIX}"/usr/bin/assistant Assistant \
"${EPREFIX}"/usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' ||
die "make_desktop_entry failed"
+
+ if use compat; then
+ insinto /usr/share/qt4/mkspecs/features || die "insinto failed"
+ doins tools/assistant/compat/features/assistant.prf || die "doins failed"
+ fi
}