summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-06-07 07:21:33 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-06-07 07:21:33 +0000
commitac8e1fdf8d615b0c2a2d5b770a5969ccf045d70b (patch)
tree6e2d12c2acf0fd737befc07480a1aa954b851650 /x11-libs/pango
parentBump (diff)
downloadgentoo-2-ac8e1fdf8d615b0c2a2d5b770a5969ccf045d70b.tar.gz
gentoo-2-ac8e1fdf8d615b0c2a2d5b770a5969ccf045d70b.tar.bz2
gentoo-2-ac8e1fdf8d615b0c2a2d5b770a5969ccf045d70b.zip
Version bump, user configuration files are now in ~/.config/pango by default.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog8
-rw-r--r--x11-libs/pango/files/pango-1.30.1-coretext-hash.patch75
-rw-r--r--x11-libs/pango/pango-1.30.1.ebuild99
3 files changed, 181 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index d4ff198c7491..2fdd972132b3 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/pango
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.347 2012/05/20 19:31:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.348 2012/06/07 07:21:33 tetromino Exp $
+
+*pango-1.30.1 (07 Jun 2012)
+
+ 07 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +pango-1.30.1.ebuild, +files/pango-1.30.1-coretext-hash.patch:
+ Version bump, user configuration files are now in ~/.config/pango by default.
20 May 2012; Samuli Suominen <ssuominen@gentoo.org> pango-1.29.4.ebuild:
ppc stable wrt #407643
diff --git a/x11-libs/pango/files/pango-1.30.1-coretext-hash.patch b/x11-libs/pango/files/pango-1.30.1-coretext-hash.patch
new file mode 100644
index 000000000000..31d8c502db6d
--- /dev/null
+++ b/x11-libs/pango/files/pango-1.30.1-coretext-hash.patch
@@ -0,0 +1,75 @@
+From 70a85d441d973883af4afb57599bc570eeea4c83 Mon Sep 17 00:00:00 2001
+From: Kristian Rietveld <kris@loopnest.org>
+Date: Tue, 5 Jun 2012 22:34:59 +0200
+Subject: [PATCH] coretext: don't insert item in the hash if it originated
+ from the hash
+
+Oversight in my fallback fix, this resulted in things being wrongly
+destroyed due to unrefs. Oops.
+---
+ pango/pangocoretext-fontmap.c | 25 ++++++++++++++-----------
+ 1 files changed, 14 insertions(+), 11 deletions(-)
+
+diff --git a/pango/pangocoretext-fontmap.c b/pango/pangocoretext-fontmap.c
+index a856593..034d050 100644
+--- a/pango/pangocoretext-fontmap.c
++++ b/pango/pangocoretext-fontmap.c
+@@ -1284,13 +1284,11 @@ pango_core_text_font_map_load_fontset (PangoFontMap *fontmap,
+
+ if (G_UNLIKELY (!fontset))
+ {
++ gboolean insert_in_hash = TRUE;
++
+ fontset = pango_core_text_fontset_new (&key, desc);
+
+- if (G_LIKELY (fontset))
+- g_hash_table_insert (ctfontmap->fontset_hash,
+- pango_core_text_fontset_get_key (fontset),
+- fontset);
+- else
++ if (G_UNLIKELY (!fontset))
+ {
+ /* If no font(set) could be loaded, we fallback to "Sans",
+ * which should always work on Mac. We try to adhere to the
+@@ -1308,7 +1306,9 @@ pango_core_text_font_map_load_fontset (PangoFontMap *fontmap,
+ language);
+
+ fontset = g_hash_table_lookup (ctfontmap->fontset_hash, &key);
+- if (G_UNLIKELY (!fontset))
++ if (G_LIKELY (fontset))
++ insert_in_hash = FALSE;
++ else
+ fontset = pango_core_text_fontset_new (&key, tmp_desc);
+
+ if (G_UNLIKELY (!fontset))
+@@ -1335,7 +1335,9 @@ pango_core_text_font_map_load_fontset (PangoFontMap *fontmap,
+ }
+
+ fontset = g_hash_table_lookup (ctfontmap->fontset_hash, &key);
+- if (G_UNLIKELY (!fontset))
++ if (G_LIKELY (fontset))
++ insert_in_hash = FALSE;
++ else
+ fontset = pango_core_text_fontset_new (&key, tmp_desc);
+
+ if (G_UNLIKELY (!fontset))
+@@ -1346,11 +1348,12 @@ pango_core_text_font_map_load_fontset (PangoFontMap *fontmap,
+ g_error ("Could not load fallback font, bailing out.");
+ }
+ }
+-
+- g_hash_table_insert (ctfontmap->fontset_hash,
+- pango_core_text_fontset_get_key (fontset),
+- fontset);
+ }
++
++ if (insert_in_hash)
++ g_hash_table_insert (ctfontmap->fontset_hash,
++ pango_core_text_fontset_get_key (fontset),
++ fontset);
+ }
+
+ /* Cannot use pango_core_text_fontset_key_free() here */
+--
+1.7.8.6
+
diff --git a/x11-libs/pango/pango-1.30.1.ebuild b/x11-libs/pango/pango-1.30.1.ebuild
new file mode 100644
index 000000000000..7f1ceac8fc74
--- /dev/null
+++ b/x11-libs/pango/pango-1.30.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.30.1.ebuild,v 1.1 2012/06/07 07:21:33 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 multilib toolchain-funcs
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="X doc +introspection test"
+
+# Upstream bug #643802
+REQUIRED_USE="doc? ( X )"
+
+RDEPEND=">=dev-libs/glib-2.31.0:2
+ >=media-libs/fontconfig-2.5.0:1.0
+ media-libs/freetype:2
+ >=x11-libs/cairo-1.7.6[X?]
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ >=x11-libs/libXft-2.0.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/gtk-doc-am-1.13
+ doc? (
+ >=dev-util/gtk-doc-1.13
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-libs/libXft )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ test? (
+ >=dev-util/gtk-doc-1.13
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-libs/libXft )
+ X? ( x11-proto/xproto )
+ !<=sys-devel/autoconf-2.63:2.5"
+
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" = "lib32" ] )
+}
+
+pkg_setup() {
+ tc-export CXX
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_with X x)
+ $(use X && echo --x-includes=${EPREFIX}/usr/include)
+ $(use X && echo --x-libraries=${EPREFIX}/usr/$(get_libdir))"
+ DOCS="AUTHORS ChangeLog* NEWS README THANKS"
+}
+
+src_prepare() {
+ # In next release
+ epatch "${FILESDIR}/${P}-coretext-hash.patch"
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system. Fix building for
+ # emul-linux-x86-gtklibs
+ if multilib_enabled ; then
+ epatch "${FILESDIR}/${PN}-1.26.0-lib64.patch"
+ eautoreconf
+ fi
+
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ einfo "Generating modules listing..."
+
+ local PANGO_CONFDIR="${EROOT}/etc/pango"
+ multilib_enabled && PANGO_CONFDIR+="/${CHOST}"
+
+ mkdir -p "${PANGO_CONFDIR}"
+ local pango_conf="${PANGO_CONFDIR}/pango.modules"
+ local tmp_file=$(mktemp -t tmp.XXXXXXXXXXgdk_pixbuf_ebuild)
+
+ # be atomic!
+ if pango-querymodules --system \
+ "${EROOT}"usr/$(get_libdir)/pango/1.6.0/modules/*.so \
+ > "${tmp_file}"; then
+ cat "${tmp_file}" > "${pango_conf}" || {
+ rm "${tmp_file}"; die; }
+ else
+ ewarn "Cannot update pango.modules, file generation failed"
+ fi
+ rm "${tmp_file}"
+
+ elog "In >=${PN}-1.30.1, default configuration file locations moved from"
+ elog "~/.pangorc and ~/.pangox_aliases to ~/.config/pango/pangorc and"
+ elog "~/.config/pango/pangox.aliases"
+}