summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 17:06:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 17:06:59 +0000
commit89f439f20533facdafd41477c5396bafb9d618cc (patch)
treeb09e27a5f251fce02ef2bbca197726bd52366e9e /x11-libs/libxcb
parentMake repoman happy by defining empty IUSE (diff)
downloadgentoo-2-89f439f20533facdafd41477c5396bafb9d618cc.tar.gz
gentoo-2-89f439f20533facdafd41477c5396bafb9d618cc.tar.bz2
gentoo-2-89f439f20533facdafd41477c5396bafb9d618cc.zip
Move use_ functions out of global scope.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/ChangeLog6
-rw-r--r--x11-libs/libxcb/libxcb-1.1.90.1.ebuild12
-rw-r--r--x11-libs/libxcb/libxcb-1.1.ebuild6
3 files changed, 16 insertions, 8 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index 806f99023bc1..971b0ea47beb 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libxcb
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.29 2009/02/06 10:48:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.30 2009/05/04 17:06:59 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> libxcb-1.1.ebuild,
+ libxcb-1.1.90.1.ebuild:
+ Move use_ functions out of global scope.
06 Feb 2009; Raúl Porcel <armin76@gentoo.org> libxcb-1.1.ebuild:
arm/ia64/s390/sh stable wrt #244210
diff --git a/x11-libs/libxcb/libxcb-1.1.90.1.ebuild b/x11-libs/libxcb/libxcb-1.1.90.1.ebuild
index 6854ea9b977a..526e997db854 100644
--- a/x11-libs/libxcb/libxcb-1.1.90.1.ebuild
+++ b/x11-libs/libxcb/libxcb-1.1.90.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.90.1.ebuild,v 1.1 2008/07/30 22:38:05 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.90.1.ebuild,v 1.2 2009/05/04 17:06:59 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -21,9 +21,11 @@ DEPEND="${RDEPEND}
dev-libs/libxslt
>=x11-proto/xcb-proto-1.2"
-CONFIGURE_OPTIONS="$(use_enable doc build-docs)
- $(use_enable selinux xselinux)
- --enable-xinput"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable doc build-docs)
+ $(use_enable selinux xselinux)
+ --enable-xinput"
+}
pkg_postinst() {
x-modular_pkg_postinst
diff --git a/x11-libs/libxcb/libxcb-1.1.ebuild b/x11-libs/libxcb/libxcb-1.1.ebuild
index 8271a916bd21..a4ae04a4f4cd 100644
--- a/x11-libs/libxcb/libxcb-1.1.ebuild
+++ b/x11-libs/libxcb/libxcb-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.ebuild,v 1.10 2009/02/06 10:48:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.ebuild,v 1.11 2009/05/04 17:06:59 ssuominen Exp $
# Must be before x-modular eclass is inherited
SNAPSHOT="yes"
@@ -21,7 +21,9 @@ DEPEND="${RDEPEND}
dev-libs/libxslt
~x11-proto/xcb-proto-${PV}"
-CONFIGURE_OPTIONS="$(use_enable doc build-docs)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable doc build-docs)"
+}
pkg_postinst() {
x-modular_pkg_postinst