summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-01-04 08:19:55 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-01-04 08:19:55 +0000
commit4f0a011ec6dab546ce1c195551d362ed748bbc7f (patch)
tree06fd2527c7d839ee6e9f4bc0f84de947182772fd /x11-libs/libvdpau
parentBump dev-python/dulwich to 0.4.1. (diff)
downloadgentoo-2-4f0a011ec6dab546ce1c195551d362ed748bbc7f.tar.gz
gentoo-2-4f0a011ec6dab546ce1c195551d362ed748bbc7f.tar.bz2
gentoo-2-4f0a011ec6dab546ce1c195551d362ed748bbc7f.zip
revert the change that 0.3 makes to assume that VDPAU libraries are in /usr/lib/vdpau because the usage of dlopen() is incorrect in this case. Need to discuss this with upstream further
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libvdpau')
-rw-r--r--x11-libs/libvdpau/ChangeLog11
-rw-r--r--x11-libs/libvdpau/libvdpau-0.3-r1.ebuild41
2 files changed, 50 insertions, 2 deletions
diff --git a/x11-libs/libvdpau/ChangeLog b/x11-libs/libvdpau/ChangeLog
index c6c9754586f9..b9cd2829c846 100644
--- a/x11-libs/libvdpau/ChangeLog
+++ b/x11-libs/libvdpau/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libvdpau
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.6 2009/11/21 03:13:39 cardoe Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.7 2010/01/04 08:19:55 cardoe Exp $
+
+*libvdpau-0.3-r1 (04 Jan 2010)
+
+ 04 Jan 2010; Doug Goldstein <cardoe@gentoo.org> +libvdpau-0.3-r1.ebuild:
+ revert the change that 0.3 makes to assume that VDPAU libraries are in
+ /usr/lib/vdpau because the usage of dlopen() is incorrect in this case.
+ Need to discuss this with upstream further
*libvdpau-0.3 (21 Nov 2009)
diff --git a/x11-libs/libvdpau/libvdpau-0.3-r1.ebuild b/x11-libs/libvdpau/libvdpau-0.3-r1.ebuild
new file mode 100644
index 000000000000..7e3c865f1959
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-0.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/libvdpau-0.3-r1.ebuild,v 1.1 2010/01/04 08:19:55 cardoe Exp $
+
+EAPI="2"
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="http://people.freedesktop.org/~aplattner/vdpau/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+#unfortunately, there's driver versions in between that this works with
+RDEPEND="x11-libs/libX11
+ !=x11-drivers/nvidia-drivers-180.29
+ !=x11-drivers/nvidia-drivers-180.60
+ !=x11-drivers/nvidia-drivers-185.18.14
+ !=x11-drivers/nvidia-drivers-185.18.29
+ !=x11-drivers/nvidia-drivers-185.18.31
+ !=x11-drivers/nvidia-drivers-185.18.36
+ !=x11-drivers/nvidia-drivers-190.18
+ !=x11-drivers/nvidia-drivers-190.25
+ !=x11-drivers/nvidia-drivers-190.32
+ !=x11-drivers/nvidia-drivers-190.36
+ !=x11-drivers/nvidia-drivers-190.40"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz
+ dev-tex/pdftex )"
+
+src_configure() {
+ econf --with-module-dir="/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}