summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-26 16:37:38 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-26 16:37:38 +0000
commit3cab744a4567d1682524a1333467ceedc526711e (patch)
treeb602035b1db40e3eb7520b6efcbc7805082b08ef /x11-libs/libvdpau
parentEnable multilib. (diff)
downloadgentoo-2-3cab744a4567d1682524a1333467ceedc526711e.tar.gz
gentoo-2-3cab744a4567d1682524a1333467ceedc526711e.tar.bz2
gentoo-2-3cab744a4567d1682524a1333467ceedc526711e.zip
Enable multilib.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'x11-libs/libvdpau')
-rw-r--r--x11-libs/libvdpau/ChangeLog10
-rw-r--r--x11-libs/libvdpau/libvdpau-0.5-r1.ebuild45
2 files changed, 52 insertions, 3 deletions
diff --git a/x11-libs/libvdpau/ChangeLog b/x11-libs/libvdpau/ChangeLog
index 5518bb4f5c16..5295840c6eb3 100644
--- a/x11-libs/libvdpau/ChangeLog
+++ b/x11-libs/libvdpau/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libvdpau
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.26 2012/11/22 10:06:42 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.27 2013/02/26 16:37:38 mgorny Exp $
+
+*libvdpau-0.5-r1 (26 Feb 2013)
+
+ 26 Feb 2013; Michał Górny <mgorny@gentoo.org> +libvdpau-0.5-r1.ebuild:
+ Enable multilib.
22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> libvdpau-0.5.ebuild:
Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
@@ -112,4 +117,3 @@
+metadata.xml:
initial version. this library wraps VDPAU. marked as mirror restrict until
upstream creates a make dist tarball and we switch to that
-
diff --git a/x11-libs/libvdpau/libvdpau-0.5-r1.ebuild b/x11-libs/libvdpau/libvdpau-0.5-r1.ebuild
new file mode 100644
index 000000000000..93a595e8f32e
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-0.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/libvdpau-0.5-r1.ebuild,v 1.1 2013/02/26 16:37:38 mgorny Exp $
+
+EAPI=5
+inherit autotools-multilib
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="http://people.freedesktop.org/~aplattner/vdpau/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dri"
+
+RDEPEND="x11-libs/libX11[${MULTILIB_USEDEP}]
+ dri? ( x11-libs/libXext[${MULTILIB_USEDEP}] )
+ !=x11-drivers/nvidia-drivers-180*
+ !=x11-drivers/nvidia-drivers-185*
+ !=x11-drivers/nvidia-drivers-190*
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-xlibs-20130224 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )
+ dri? ( >=x11-proto/dri2proto-2.2 )"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable doc documentation)
+ $(use dri || echo --disable-dri2)
+ )
+
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ prune_libtool_files --modules
+}