summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-23 01:50:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-23 01:50:33 +0000
commitb1ec65e14a9a37de0dd074e2f162aa15d14a942c (patch)
tree2670dcf397fa17679ddc6b7d62219e7e21d095eb /x11-libs/libnotify
parentppc64 stable wrt #388011 (diff)
downloadgentoo-2-b1ec65e14a9a37de0dd074e2f162aa15d14a942c.tar.gz
gentoo-2-b1ec65e14a9a37de0dd074e2f162aa15d14a942c.tar.bz2
gentoo-2-b1ec65e14a9a37de0dd074e2f162aa15d14a942c.zip
Rename notify-send to libnotify-notify-send and symlink it to notify-send with USE="symlink" wrt #379941 by Michał Górny
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libnotify')
-rw-r--r--x11-libs/libnotify/ChangeLog11
-rw-r--r--x11-libs/libnotify/libnotify-0.7.4-r1.ebuild56
-rw-r--r--x11-libs/libnotify/metadata.xml9
3 files changed, 70 insertions, 6 deletions
diff --git a/x11-libs/libnotify/ChangeLog b/x11-libs/libnotify/ChangeLog
index 63571b27a937..6b5537a9571a 100644
--- a/x11-libs/libnotify/ChangeLog
+++ b/x11-libs/libnotify/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libnotify
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.78 2011/11/18 22:17:12 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.79 2012/01/23 01:50:33 ssuominen Exp $
+
+*libnotify-0.7.4-r1 (23 Jan 2012)
+
+ 23 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +libnotify-0.7.4-r1.ebuild, metadata.xml:
+ Rename notify-send to libnotify-notify-send and symlink it to notify-send
+ with USE="symlink" wrt #379941 by Michał Górny
18 Nov 2011; Samuli Suominen <ssuominen@gentoo.org>
-files/libnotify-0.7.1-gtk3-tests.patch, -libnotify-0.7.2.ebuild:
diff --git a/x11-libs/libnotify/libnotify-0.7.4-r1.ebuild b/x11-libs/libnotify/libnotify-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..fee1d00a3b92
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.4-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.7.4-r1.ebuild,v 1.1 2012/01/23 01:50:33 ssuominen Exp $
+
+EAPI=4
+inherit autotools gnome.org
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="http://git.gnome.org/browse/libnotify"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/introspection-20110205.m4.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc +introspection +symlink test"
+
+RDEPEND=">=dev-libs/glib-2.26
+ x11-libs/gdk-pixbuf:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.14 )
+ symlink? ( !x11-misc/tinynotify-send[symlink] )
+ test? ( x11-libs/gtk+:3 )"
+PDEPEND="virtual/notification-daemon"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_prepare() {
+ sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
+
+ if ! use test; then
+ sed -i -e '/PKG_CHECK_MODULES(TESTS/d' configure.ac || die
+ fi
+
+ if has_version 'dev-libs/gobject-introspection'; then
+ eautoreconf
+ else
+ AT_M4DIR=${WORKDIR} eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"usr/lib*/${PN}.la
+ mv -vf "${ED}"usr/bin/{,${PN}-}notify-send #379941
+ use symlink && dosym ${PN}-notify-send /usr/bin/notify-send
+}
diff --git a/x11-libs/libnotify/metadata.xml b/x11-libs/libnotify/metadata.xml
index 0b2305e0efdc..dfd071461f7a 100644
--- a/x11-libs/libnotify/metadata.xml
+++ b/x11-libs/libnotify/metadata.xml
@@ -1,8 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>freedesktop</herd>
- <use>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
- </use>
+ <herd>freedesktop</herd>
+ <use>
+ <flag name='introspection'>Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
+ <flag name='symlink'>Create symlink from libnotify-notify-send to notify-send</flag>
+ </use>
</pkgmetadata>