summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-17 13:06:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-17 13:06:30 +0000
commit6d83f295b165ec3f39e802744a1f53aff4dbe4af (patch)
treebce2b237a7f3452ec441dceb7463724730d20218 /x11-libs/libmatchbox
parentAdding dependencies on flex and bison, as per bug #382583. Thanks to Patrick ... (diff)
downloadgentoo-2-6d83f295b165ec3f39e802744a1f53aff4dbe4af.tar.gz
gentoo-2-6d83f295b165ec3f39e802744a1f53aff4dbe4af.tar.bz2
gentoo-2-6d83f295b165ec3f39e802744a1f53aff4dbe4af.zip
Fix building with libpng15 wrt #383201 by Diego Elio Pettenò. USE="static-libs" and punt libtool archive in favour of pkg-config file.
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libmatchbox')
-rw-r--r--x11-libs/libmatchbox/ChangeLog7
-rw-r--r--x11-libs/libmatchbox/files/libmatchbox-1.9-libpng15.patch22
-rw-r--r--x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild35
3 files changed, 44 insertions, 20 deletions
diff --git a/x11-libs/libmatchbox/ChangeLog b/x11-libs/libmatchbox/ChangeLog
index e9cc58ee6229..8ede5518e735 100644
--- a/x11-libs/libmatchbox/ChangeLog
+++ b/x11-libs/libmatchbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libmatchbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/ChangeLog,v 1.18 2011/03/20 12:51:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/ChangeLog,v 1.19 2011/09/17 13:06:30 ssuominen Exp $
+
+ 17 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+ libmatchbox-1.9-r1.ebuild, +files/libmatchbox-1.9-libpng15.patch:
+ Fix building with libpng15 wrt #383201 by Diego Elio Pettenò.
+ USE="static-libs" and punt libtool archive in favour of pkg-config file.
*libmatchbox-1.9-r1 (20 Mar 2011)
diff --git a/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng15.patch b/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng15.patch
new file mode 100644
index 000000000000..25f68575032c
--- /dev/null
+++ b/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng15.patch
@@ -0,0 +1,22 @@
+--- libmb/mbpixbuf.c
++++ libmb/mbpixbuf.c
+@@ -247,7 +247,7 @@
+ return NULL;
+ }
+
+- if ( setjmp( png_ptr->jmpbuf ) ) {
++ if ( setjmp( png_jmpbuf(png_ptr) ) ) {
+ png_destroy_read_struct( &png_ptr, &info_ptr, NULL);
+ fclose(fd);
+ return NULL;
+@@ -269,8 +269,8 @@
+ ( color_type == PNG_COLOR_TYPE_GRAY_ALPHA ))
+ png_set_gray_to_rgb(png_ptr);
+
+- if ( info_ptr->color_type == PNG_COLOR_TYPE_RGB_ALPHA
+- || info_ptr->color_type == PNG_COLOR_TYPE_GRAY_ALPHA
++ if ( color_type == PNG_COLOR_TYPE_RGB_ALPHA
++ || color_type == PNG_COLOR_TYPE_GRAY_ALPHA
+ )
+ *has_alpha = 1;
+ else
diff --git a/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild b/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild
index b9e3276adfc8..8fc5fd8fca85 100644
--- a/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild
+++ b/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild,v 1.1 2011/03/20 12:51:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild,v 1.2 2011/09/17 13:06:30 ssuominen Exp $
+EAPI=4
inherit eutils libtool
DESCRIPTION="The Matchbox Library."
HOMEPAGE="http://matchbox-project.org/"
SRC_URI="http://matchbox-project.org/sources/${PN}/${PV}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
-IUSE="debug doc jpeg pango png test truetype X xsettings"
+IUSE="debug doc jpeg pango png static-libs test truetype X xsettings"
RDEPEND="x11-libs/libXext
truetype? ( x11-libs/libXft )
@@ -27,27 +28,26 @@ DEPEND="${RDEPEND}
# Test suite broken, missing files and such.
RESTRICT="test"
+DOCS=( AUTHORS ChangeLog NEWS README )
+
pkg_setup() {
# Bug #138135
if use truetype && use pango; then
ewarn "You have both the truetype and pango USE flags set, pango"
ewarn "overrides and disables the XFT support truetype enables."
ewarn "If this isn't what you intended you should stop the build!"
- ebeep 3
- epause 3
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-libpng14.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng1{4,5}.patch
elibtoolize
}
-src_compile() {
- econf $(use_enable debug) \
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
$(use_enable doc doxygen-docs) \
$(use_enable truetype xft) \
$(use_enable pango) \
@@ -55,15 +55,12 @@ src_compile() {
$(use_enable png) \
$(use_enable xsettings) \
$(use_with X x) \
- $(use_enable test unit-tests) \
- || die "Configuration failed"
-
- emake || die "Compilation failed"
+ $(use_enable test unit-tests)
}
src_install() {
- make DESTDIR="${D}" install || die "Installation failed"
-
- dodoc AUTHORS ChangeLog INSTALL NEWS README
+ default
use doc && dohtml doc/html/*
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
}