summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-26 15:22:30 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-26 15:22:30 +0000
commit8ffad4e0b1a99e744cad2a0008fcfbb9be0c128a (patch)
tree678e5236de250d42db9a717a8f4e406933dfd7e2 /x11-libs/libSM
parentAdd ~arm-linux and ~x86-linux keywords. (diff)
downloadgentoo-2-8ffad4e0b1a99e744cad2a0008fcfbb9be0c128a.tar.gz
gentoo-2-8ffad4e0b1a99e744cad2a0008fcfbb9be0c128a.tar.bz2
gentoo-2-8ffad4e0b1a99e744cad2a0008fcfbb9be0c128a.zip
Enable multilib.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'x11-libs/libSM')
-rw-r--r--x11-libs/libSM/ChangeLog7
-rw-r--r--x11-libs/libSM/libSM-1.2.1-r1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/x11-libs/libSM/ChangeLog b/x11-libs/libSM/ChangeLog
index 70a0e11dce81..1b4b4aba996f 100644
--- a/x11-libs/libSM/ChangeLog
+++ b/x11-libs/libSM/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libSM
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/ChangeLog,v 1.101 2013/02/22 18:03:01 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/ChangeLog,v 1.102 2013/02/26 15:22:30 mgorny Exp $
+
+*libSM-1.2.1-r1 (26 Feb 2013)
+
+ 26 Feb 2013; Michał Górny <mgorny@gentoo.org> +libSM-1.2.1-r1.ebuild:
+ Enable multilib.
22 Feb 2013; Zac Medico <zmedico@gentoo.org> libSM-1.2.1.ebuild:
Add ~arm-linux keyword.
diff --git a/x11-libs/libSM/libSM-1.2.1-r1.ebuild b/x11-libs/libSM/libSM-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..b2b68ce5c43a
--- /dev/null
+++ b/x11-libs/libSM/libSM-1.2.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/libSM-1.2.1-r1.ebuild,v 1.1 2013/02/26 15:22:30 mgorny Exp $
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org SM library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc ipv6 +uuid"
+
+RDEPEND=">=x11-libs/libICE-1.0.5[${MULTILIB_USEDEP}]
+ x11-libs/xtrans
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ !elibc_FreeBSD? ( !elibc_SunOS? (
+ uuid? (
+ >=sys-apps/util-linux-2.16
+ amd64? ( abi_x86_32? (
+ app-emulation/emul-linux-x86-baselibs[development] ) )
+ )
+ ) )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ local withuuid=$(use_with uuid libuuid)
+ xorg-2_pkg_setup
+
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+
+ if use uuid ; then
+ case ${CHOST} in
+ *-solaris*|*-darwin*)
+ if [[ ! -d ${EROOT}usr/include/uuid ]] &&
+ [[ -d ${ROOT}usr/include/uuid ]]
+ then
+ # Solaris and Darwin have uuid provided by the host
+ # system. Since util-linux's version is based on this
+ # version, and on Darwin actually breaks host headers when
+ # installed, we can "pretend" for libSM we have libuuid
+ # installed, while in fact we don't
+ withuuid="--without-libuuid"
+ export HAVE_LIBUUID=yes
+ export LIBUUID_CFLAGS="-I${ROOT}usr/include/uuid"
+ # Darwin has uuid in libSystem
+ [[ ${CHOST} == *-solaris* ]] && export LIBUUID_LIBS="-luuid"
+ fi
+ ;;
+ esac
+ fi
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ ${withuuid}
+ --without-fop
+ )
+}