summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-28 21:29:29 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-28 21:29:29 +0000
commit91f2fe8d8b967cec8025d3a122f883213b020f92 (patch)
treed9a017aceca98cc7307c4b28c319bf0226a7b1a1 /x11-libs/gtksourceview
parentVersion bump. Translation updates. (diff)
downloadgentoo-2-91f2fe8d8b967cec8025d3a122f883213b020f92.tar.gz
gentoo-2-91f2fe8d8b967cec8025d3a122f883213b020f92.tar.bz2
gentoo-2-91f2fe8d8b967cec8025d3a122f883213b020f92.zip
Version bump. Translation updates.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog8
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.10.5.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index 66082efee85a..afdd369007d9 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.185 2010/09/11 18:35:26 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.186 2010/09/28 21:29:29 eva Exp $
+
+*gtksourceview-2.10.5 (28 Sep 2010)
+
+ 28 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtksourceview-2.10.5.ebuild:
+ Version bump. Translation updates.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> gtksourceview-2.10.4.ebuild:
Marked ppc for bug #324077.
diff --git a/x11-libs/gtksourceview/gtksourceview-2.10.5.ebuild b/x11-libs/gtksourceview/gtksourceview-2.10.5.ebuild
new file mode 100644
index 000000000000..e4ab9d381b51
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-2.10.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.10.5.ebuild,v 1.1 2010/09/28 21:29:29 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc glade"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/glib-2.14
+ glade? ( >=dev-util/glade-3.2 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+
+pkg_config() {
+ G2CONF="${G2CONF}
+ --disable-maintainer-mode
+ $(use-enable glade glade-catalog)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Skip broken test until upstream bug #621383 is solved
+ sed -i -e "/guess-language/d" tests/test-languagemanager.c || die
+}
+
+src_test() {
+ Xemake check || die "Test phase failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-2.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang || die "doins failed"
+}