summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-10 05:53:07 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-10 05:53:07 +0000
commit2e7e6c5625b074d28374a704984c4b305c746c31 (patch)
treebaf8dc49a264d843fe252fad1c93d808ed5e93b8 /x11-libs/gtkglext/gtkglext-1.2.0-r1.ebuild
parentRemove duplicate patch file. (diff)
downloadgentoo-2-2e7e6c5625b074d28374a704984c4b305c746c31.tar.gz
gentoo-2-2e7e6c5625b074d28374a704984c4b305c746c31.tar.bz2
gentoo-2-2e7e6c5625b074d28374a704984c4b305c746c31.zip
Add virtual/glu dependency for mesa-9, bug #434426, thanks to Andreas Sturmlechner. Add missing X deps. Revbump to drop static libraries and .la files.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtkglext/gtkglext-1.2.0-r1.ebuild')
-rw-r--r--x11-libs/gtkglext/gtkglext-1.2.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-libs/gtkglext/gtkglext-1.2.0-r1.ebuild b/x11-libs/gtkglext/gtkglext-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..77cdf7c01667
--- /dev/null
+++ b/x11-libs/gtkglext/gtkglext-1.2.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglext/gtkglext-1.2.0-r1.ebuild,v 1.1 2012/09/10 05:53:07 tetromino Exp $
+
+EAPI="4"
+
+GNOME2_LA_PUNT="yes"
+inherit gnome2
+
+DESCRIPTION="GL extensions for Gtk+ 2.0"
+HOMEPAGE="http://gtkglext.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2:2
+ >=x11-libs/gtk+-2:2
+ >=x11-libs/pango-1[X]
+ x11-libs/libX11
+ x11-libs/libXmu
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog* NEWS README TODO"
+ G2CONF="${G2CONF} --disable-static"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove development knobs, bug #308973
+ sed -i 's:-D\(G.*DISABLE_DEPRECATED\):-D__\1__:g' \
+ examples/Makefile.am examples/Makefile.in \
+ gdk/Makefile.am gdk/Makefile.in \
+ gdk/win32/Makefile.am gdk/win32/Makefile.in \
+ gdk/x11/Makefile.am gdk/x11/Makefile.in \
+ gtk/Makefile.am gtk/Makefile.in \
+ || die "sed failed"
+}