summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2006-01-07 07:09:33 +0000
committerJoe McCann <joem@gentoo.org>2006-01-07 07:09:33 +0000
commit8b17099d64b0f8eeb832822849dd6688b84b890e (patch)
tree3eb8ecf7e241abfb066eab0b987de6e3f5766243 /x11-libs/goffice/goffice-0.1.2.ebuild
parentCleanup ebuild and fix building when xv is disabled. (diff)
downloadgentoo-2-8b17099d64b0f8eeb832822849dd6688b84b890e.tar.gz
gentoo-2-8b17099d64b0f8eeb832822849dd6688b84b890e.tar.bz2
gentoo-2-8b17099d64b0f8eeb832822849dd6688b84b890e.zip
version bump
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'x11-libs/goffice/goffice-0.1.2.ebuild')
-rw-r--r--x11-libs/goffice/goffice-0.1.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-libs/goffice/goffice-0.1.2.ebuild b/x11-libs/goffice/goffice-0.1.2.ebuild
new file mode 100644
index 000000000000..7555d17d256b
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.1.2.ebuild,v 1.1 2006/01/07 07:09:33 joem Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://freshmeat.net/projects/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnome"
+#cairo support broken and -gtk broken
+
+RDEPEND=">=dev-libs/glib-2.6.3
+ >=gnome-extra/libgsf-1.13.3
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.6
+ >=gnome-base/libgnomeprint-2.8.2
+ >=media-libs/libart_lgpl-2.3.11
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+USE_DESTDIR="1"
+
+
+pkg_setup() {
+ G2CONF="$(use_with gnome)"
+
+ if use gnome && ! built_with_use gnome-extra/libgsf gnome; then
+ eerror "Please rebuild gnome-extra/libgsf with gnome support enabled"
+ eerror "USE=\"gnome\" emerge gnome-extra/libgsf"
+ eerror "or add \"gnome\" to your USE string in /etc/make.conf"
+ die "No Gnome support found in libgsf"
+ fi
+}