summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-04-02 03:05:33 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-04-02 03:05:33 +0000
commit78127762c43cd8a47928d40103d5858d4d164924 (patch)
tree34685cb1938486f8359f81ade5e30291065ddced /x11-libs/fox
parentRevision bump; added diff to fix action bash glob. (diff)
downloadgentoo-2-78127762c43cd8a47928d40103d5858d4d164924.tar.gz
gentoo-2-78127762c43cd8a47928d40103d5858d4d164924.tar.bz2
gentoo-2-78127762c43cd8a47928d40103d5858d4d164924.zip
Updated to use econf and make DESTDIR="${D}" install
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/ChangeLog8
-rw-r--r--x11-libs/fox/files/digest-fox-1.2.6-r31
-rw-r--r--x11-libs/fox/fox-1.2.6-r3.ebuild42
-rw-r--r--x11-libs/fox/fox-1.4.11.ebuild5
4 files changed, 52 insertions, 4 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
index da9f3373b09f..85f7440c3b07 100644
--- a/x11-libs/fox/ChangeLog
+++ b/x11-libs/fox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/fox
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.38 2005/04/01 21:12:09 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.39 2005/04/02 03:05:33 eradicator Exp $
+
+*fox-1.2.6-r3 (02 Apr 2005)
+
+ 02 Apr 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ +fox-1.2.6-r3.ebuild, fox-1.4.11.ebuild:
+ Updated to use econf and make DESTDIR="${D}" install
01 Apr 2005; <rphillips@gentoo.org> fox-1.4.11.ebuild:
Updated ebuild to use emake and einstall. Thanks to Diego. Fixes #74872
diff --git a/x11-libs/fox/files/digest-fox-1.2.6-r3 b/x11-libs/fox/files/digest-fox-1.2.6-r3
new file mode 100644
index 000000000000..9f20cdacf989
--- /dev/null
+++ b/x11-libs/fox/files/digest-fox-1.2.6-r3
@@ -0,0 +1 @@
+MD5 a178e70c8ec1422ead2216f6406d3679 fox-1.2.6.tar.gz 3770911
diff --git a/x11-libs/fox/fox-1.2.6-r3.ebuild b/x11-libs/fox/fox-1.2.6-r3.ebuild
new file mode 100644
index 000000000000..c94d3d0f45d4
--- /dev/null
+++ b/x11-libs/fox/fox-1.2.6-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.2.6-r3.ebuild,v 1.1 2005/04/02 03:05:33 eradicator Exp $
+
+IUSE="cups debug truetype opengl"
+DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily and effectively"
+SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.fox-toolkit.org"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~hppa ~alpha ~ppc64"
+LICENSE="GPL-2"
+
+DEPEND="virtual/libc
+ virtual/x11
+ truetype? ( >=media-libs/freetype-2.1.5-r1 )
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+ local myconf
+
+ use opengl || myconf="$myconf --with-opengl=no" #default enabled
+ myconf="$myconf `use_enable cups`" #default disabled
+ myconf="$myconf `use_enable debug`" #default disabled
+ use truetype && myconf="$myconf --with-xft" #default disabled
+
+ # Following line closes #61694
+ CPPFLAGS="$CPPFLAGS -I/usr/include/freetype2" \
+ econf ${myconf}
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
+ rmdir ${D}/usr/fox/html
+ rmdir ${D}/usr/fox
+}
diff --git a/x11-libs/fox/fox-1.4.11.ebuild b/x11-libs/fox/fox-1.4.11.ebuild
index e1ddd3715ffb..a6770366a583 100644
--- a/x11-libs/fox/fox-1.4.11.ebuild
+++ b/x11-libs/fox/fox-1.4.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.4.11.ebuild,v 1.2 2005/04/01 21:12:09 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.4.11.ebuild,v 1.3 2005/04/02 03:05:33 eradicator Exp $
IUSE="cups debug truetype opengl X tiff png jpeg zlib bzlib"
DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily and effectively"
@@ -43,8 +43,7 @@ src_compile() {
}
src_install () {
-
- einstall
+ make DESTDIR="${D}" install || die
dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING