summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-16 18:46:20 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-16 18:46:20 +0000
commit96ead4b027e05510f0220feb585b003f2ebcdcef (patch)
tree094c54d33b8efe66fe56f30f0828244586800604 /x11-drivers
parenttook out the groupadd stuff, since usb seems to be in /etc/group by default. ... (diff)
downloadgentoo-2-96ead4b027e05510f0220feb585b003f2ebcdcef.tar.gz
gentoo-2-96ead4b027e05510f0220feb585b003f2ebcdcef.tar.bz2
gentoo-2-96ead4b027e05510f0220feb585b003f2ebcdcef.zip
Add detect-dga-cpio-etc-per-platform.patch, which should make things work for ppc.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog10
-rw-r--r--x11-drivers/xf86-video-ati/files/detect-dga-cpio-etc-per-platform.patch117
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.6-r11
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6-r1.ebuild26
4 files changed, 153 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 3068a88b2786..3b65375e3468 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.2 2005/08/08 19:46:13 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.3 2005/08/16 18:46:20 spyderous Exp $
+
+*xf86-video-ati-6.5.6-r1 (16 Aug 2005)
+
+ 16 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/detect-dga-cpio-etc-per-platform.patch,
+ +xf86-video-ati-6.5.6-r1.ebuild:
+ Add detect-dga-cpio-etc-per-platform.patch, which should make things work
+ for ppc.
08 Aug 2005; Ferris McCormick <fmccor@gentoo.org>
xf86-video-ati-6.5.6.ebuild:
diff --git a/x11-drivers/xf86-video-ati/files/detect-dga-cpio-etc-per-platform.patch b/x11-drivers/xf86-video-ati/files/detect-dga-cpio-etc-per-platform.patch
new file mode 100644
index 000000000000..7c9971a26312
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/detect-dga-cpio-etc-per-platform.patch
@@ -0,0 +1,117 @@
+diff -urN xf86-video-ati-6.5.6.orig/configure.ac xf86-video-ati-6.5.6/configure.ac
+--- xf86-video-ati-6.5.6.orig/configure.ac 2005-08-01 13:15:22.000000000 -0700
++++ xf86-video-ati-6.5.6/configure.ac 2005-08-16 11:27:10.000000000 -0700
+@@ -88,6 +88,74 @@
+ AC_DEFINE(XF86DRI_DEVEL,1,[Enable developmental DRI driver support])
+ fi
+
++# Note that this is sort of inverted from drivers/ati/Imakefile in
++# the monolith. We test for foo, not for !foo (i.e. ATMISC_CPIO, not
++# ATIMISC_AVOID_CPIO), but the defines are negative. So beware. Oh yeah,
++# TV_OUT is the special case where it's a positive define, not AVOID_TV_OUT.
++
++# AVOID_CPIO: Only x86, amd64, and alpha are cool with CPIO. It needs a
++# little-endian, undirected PIO space of at least 64kB.
++# AVOID_NON_PCI: Platforms which don't deal with PCI master aborts should
++# stick to PCI-only probing, stick their fingers in their ears, and pretend
++# that ISA cards simply don't exist.
++# AVOID_DGA: ???
++# ATI_TV_OUT: This only works on x86.
++
++ATIMISC_CPIO=no
++ATIMISC_NON_PCI=yes
++ATIMISC_DGA=yes
++ATIMISC_TV_OUT=no
++
++case $host_cpu in
++ i*86)
++ ATIMISC_TV_OUT=yes
++ ATIMISC_CPIO=yes
++ ;;
++ amd64|alpha)
++ ATIMISC_CPIO=yes
++ ;;
++ sparc)
++ ATIMISC_DGA=no
++ ;;
++ powerpc)
++ ATIMISC_NON_PCI=no
++ ;;
++ *)
++ ;;
++esac
++
++AC_MSG_CHECKING([whether to include PIO support])
++AM_CONDITIONAL(ATIMISC_CPIO, test "x$ATIMISC_CPIO" = xyes)
++if test "x$ATIMISC_CPIO" = xyes; then
++ echo "yes, PIO"
++else
++ AC_DEFINE(AVOID_CPIO, 1, [Avoid PIO and use MMIO for atimisc.])
++ echo "no, MMIO"
++fi
++
++AC_MSG_CHECKING([whether to include support for non-PCI devices])
++AM_CONDITIONAL(ATIMISC_NON_PCI, test "x$ATIMISC_NON_PCI" = xyes)
++if test "x$ATI_AVOID_NON_PCI" = xyes; then
++ echo "yes, PCI and ISA"
++else
++ AC_DEFINE(AVOID_NON_PCI, 1, [Only probe PCI cards; do not probe ISA.])
++ echo "no, PCI only"
++fi
++
++AC_MSG_CHECKING([whether to include DGA support])
++AC_MSG_RESULT([$ATIMISC_DGA])
++AM_CONDITIONAL(ATIMISC_DGA, test "x$ATIMISC_DGA" = xyes)
++if ! test "x$ATIMISC_DGA" = xyes; then
++ AC_DEFINE(AVOID_DGA, 1, [Do not build DGA support.])
++fi
++
++AC_MSG_CHECKING([whether to include TV Out support])
++AC_MSG_RESULT([$ATIMISC_TV_OUT])
++AM_CONDITIONAL(ATIMISC_TV_OUT, test "x$ATIMISC_TV_OUT" = xyes)
++if test "x$ATIMISC_TV_OUT" = xyes; then
++ AC_DEFINE(TV_OUT, 1, [Build TV-Out support for atimisc.])
++fi
++
+ AC_SUBST([XORG_CFLAGS])
+ AC_SUBST([DRI_CFLAGS])
+ AC_SUBST([moduledir])
+diff -urN xf86-video-ati-6.5.6.orig/src/Makefile.am xf86-video-ati-6.5.6/src/Makefile.am
+--- xf86-video-ati-6.5.6.orig/src/Makefile.am 2005-08-01 13:15:22.000000000 -0700
++++ xf86-video-ati-6.5.6/src/Makefile.am 2005-08-16 11:27:10.000000000 -0700
+@@ -32,6 +32,15 @@
+ RADEON_DRI_SRCS = radeon_dri.c
+ endif
+
++if ATIMISC_CPIO
++ATI_CPIO_SOURCES = ativgaio.c
++ATIMISC_CPIO_SOURCES = ativga.c atibank.c atiwonder.c atiwonderio.c
++endif
++
++if ATIMISC_DGA
++ATIMISC_DGA_SOURCES = atidga.c
++endif
++
+ AM_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@
+
+ ati_drv_la_LTLIBRARIES = ati_drv.la
+@@ -39,7 +48,7 @@
+ ati_drv_ladir = @moduledir@/drivers
+ ati_drv_la_SOURCES = \
+ ati.c atiadapter.c atibus.c atichip.c atiident.c atioption.c \
+- atiprobe.c atividmem.c ativgaio.c atimodule.c \
++ atiprobe.c atividmem.c atimodule.c $(ATI_CPIO_SOURCES) \
+ radeon_probe.c r128_probe.c
+
+ atimisc_drv_la_LTLIBRARIES = atimisc_drv.la
+@@ -51,8 +60,8 @@
+ atilock.c atimach64.c atimach64accel.c atimach64cursor.c \
+ atimach64i2c.c atimach64io.c atimach64xv.c atimode.c atipreinit.c \
+ atiprint.c atirgb514.c atiscreen.c atituner.c atiutil.c ativalid.c \
+- atixv.c atibank.c ativga.c atiwonder.c atiwonderio.c atidga.c \
+- atiload.c atimisc.c $(ATIMISC_DRI_SRCS)
++ atixv.c atiload.c atimisc.c $(ATIMISC_DRI_SRCS) $(ATIMISC_DGA_SOURCES) \
++ $(ATIMISC_CPIO_SOURCES)
+
+ r128_drv_la_LTLIBRARIES = r128_drv.la
+ r128_drv_la_LDFLAGS = -module -avoid-version
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.6-r1 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.6-r1
new file mode 100644
index 000000000000..ee9b0e899465
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.6-r1
@@ -0,0 +1 @@
+MD5 bb4ec6a49d4c586112a6181e36fe2840 xf86-video-ati-6.5.6.tar.bz2 620648
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6-r1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6-r1.ebuild
new file mode 100644
index 000000000000..2fb93af71d53
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6-r1.ebuild,v 1.1 2005/08/16 18:46:20 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+SNAPSHOT="yes"
+
+inherit x-modular
+
+PATCHES="${FILESDIR}/detect-dga-cpio-etc-per-platform.patch"
+
+DESCRIPTION="X.Org driver for ati cards"
+KEYWORDS="~sparc ~x86"
+IUSE="dri"
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}