summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2012-02-11 16:33:16 +0000
committerMike Auty <ikelos@gentoo.org>2012-02-11 16:33:16 +0000
commit6ac97cf96d9671d536d9606608c9fd8c94fa9fe8 (patch)
treecd07af60ae4b3d9910e9d1e0093e2810023ad024 /x11-drivers
parentppc stable #402039 (diff)
downloadgentoo-2-6ac97cf96d9671d536d9606608c9fd8c94fa9fe8.tar.gz
gentoo-2-6ac97cf96d9671d536d9606608c9fd8c94fa9fe8.tar.bz2
gentoo-2-6ac97cf96d9671d536d9606608c9fd8c94fa9fe8.zip
Bump xf86-input-wacom to 0.13.0 as requested in bug 401663.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.13.0.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 7095d0e7ae79..f8f80606c7ee 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-input-wacom
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.48 2011/09/29 11:45:21 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.49 2012/02/11 16:33:16 ikelos Exp $
+
+*xf86-input-wacom-0.13.0 (11 Feb 2012)
+
+ 11 Feb 2012; Mike Auty <ikelos@gentoo.org> +xf86-input-wacom-0.13.0.ebuild:
+ Bump xf86-input-wacom to 0.13.0 as requested in bug 401663.
29 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
-xf86-input-wacom-0.10.11.ebuild, xf86-input-wacom-0.11.1.ebuild:
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.13.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.13.0.ebuild
new file mode 100644
index 000000000000..42b7db31b633
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.13.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.13.0.ebuild,v 1.1 2012/02/11 16:33:16 ikelos Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}