summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2007-05-05 16:09:13 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2007-05-05 16:09:13 +0000
commit4a2d531ff21f2606ed231db4b0a3822a47687311 (patch)
treebfe54fc9b3d317dc49cb5b47c1f474d836f95b24 /x11-drivers
parentAdd a dependency on libXfixes when building dmx. Thanks to Hopeless of (diff)
downloadgentoo-2-4a2d531ff21f2606ed231db4b0a3822a47687311.tar.gz
gentoo-2-4a2d531ff21f2606ed231db4b0a3822a47687311.tar.bz2
gentoo-2-4a2d531ff21f2606ed231db4b0a3822a47687311.zip
Version bump. I've included a small patch from GIT that fixes an off-by-one
problem. (Portage version: 2.1.2.6)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-acecad/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-acecad/files/1.2.0-off-by-one.patch24
-rw-r--r--x11-drivers/xf86-input-acecad/files/digest-xf86-input-acecad-1.2.06
-rw-r--r--x11-drivers/xf86-input-acecad/xf86-input-acecad-1.2.0.ebuild19
4 files changed, 57 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-acecad/ChangeLog b/x11-drivers/xf86-input-acecad/ChangeLog
index 8ad8b16ffeab..8d3b2ebbd4d5 100644
--- a/x11-drivers/xf86-input-acecad/ChangeLog
+++ b/x11-drivers/xf86-input-acecad/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-input-acecad
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-acecad/ChangeLog,v 1.32 2007/05/05 16:06:02 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-acecad/ChangeLog,v 1.33 2007/05/05 16:09:13 joshuabaergen Exp $
+
+*xf86-input-acecad-1.2.0 (05 May 2007)
+
+ 05 May 2007; Joshua Baergen <joshuabaergen@gentoo.org>
+ +files/1.2.0-off-by-one.patch, +xf86-input-acecad-1.2.0.ebuild:
+ Version bump. I've included a small patch from GIT that fixes an off-by-one
+ problem.
24 Jan 2007; Donnie Berkholz <dberkholz@gentoo.org>;
-xf86-input-acecad-1.0.0.5.ebuild:
diff --git a/x11-drivers/xf86-input-acecad/files/1.2.0-off-by-one.patch b/x11-drivers/xf86-input-acecad/files/1.2.0-off-by-one.patch
new file mode 100644
index 000000000000..3b19cac51510
--- /dev/null
+++ b/x11-drivers/xf86-input-acecad/files/1.2.0-off-by-one.patch
@@ -0,0 +1,24 @@
+diff --git a/src/acecad.c b/src/acecad.c
+index 1c0b4f7..c146105 100644
+--- a/src/acecad.c
++++ b/src/acecad.c
+@@ -185,7 +185,7 @@ IsUSBLine(int fd)
+ }
+ }
+
+-/* Heavily inspired by synpatics/eventcomm.c */
++/* Heavily inspired by synaptics/eventcomm.c */
+
+ #define DEV_INPUT_EVENT "/dev/input/event"
+ #define EV_DEV_NAME_MAXLEN 64
+@@ -196,8 +196,8 @@ static Bool
+ fd_query_acecad(int fd, char *ace_name) {
+ char name[256] = "Unknown";
+ int cmp_at = strlen(ace_name);
+- if (cmp_at > 256)
+- cmp_at = 256;
++ if (cmp_at > 255)
++ cmp_at = 255;
+ ioctl(fd, EVIOCGNAME(sizeof(name)), name);
+ name[cmp_at] = '\0';
+ if (xf86NameCmp(name, ace_name) == 0)
diff --git a/x11-drivers/xf86-input-acecad/files/digest-xf86-input-acecad-1.2.0 b/x11-drivers/xf86-input-acecad/files/digest-xf86-input-acecad-1.2.0
new file mode 100644
index 000000000000..651e2b63e89c
--- /dev/null
+++ b/x11-drivers/xf86-input-acecad/files/digest-xf86-input-acecad-1.2.0
@@ -0,0 +1,6 @@
+MD5 56566e8c3fb4bb99791d1788d0a9a1a8 x11-driver-patches-4.tar.bz2 346
+RMD160 fcbd405de080d07612d46f455b927035fd8123a8 x11-driver-patches-4.tar.bz2 346
+SHA256 07069bbd072f2def50e83801a8f2a41a4c96495104f15cd6f56f7df7f89769bf x11-driver-patches-4.tar.bz2 346
+MD5 15c1e7e309b72a245d5976020db29398 xf86-input-acecad-1.2.0.tar.bz2 226766
+RMD160 a23d8d04789fda018612cf65d6c3b0d7b4969416 xf86-input-acecad-1.2.0.tar.bz2 226766
+SHA256 890c284f7790ef3960f9419f95bddbe3e045f0abdcda47fcc6ccea74b6193025 xf86-input-acecad-1.2.0.tar.bz2 226766
diff --git a/x11-drivers/xf86-input-acecad/xf86-input-acecad-1.2.0.ebuild b/x11-drivers/xf86-input-acecad/xf86-input-acecad-1.2.0.ebuild
new file mode 100644
index 000000000000..ca465a23e796
--- /dev/null
+++ b/x11-drivers/xf86-input-acecad/xf86-input-acecad-1.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-acecad/xf86-input-acecad-1.2.0.ebuild,v 1.1 2007/05/05 16:09:13 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+XDPVER=4
+
+inherit x-modular
+
+DESCRIPTION="Acecad Flair input driver"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+PATCHES="${FILESDIR}/1.2.0-off-by-one.patch"