summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2011-03-22 21:33:56 +0000
committerLuca Barbato <lu_zero@gentoo.org>2011-03-22 21:33:56 +0000
commit497954347d4fb1eb31e26ba393d5a89bca56429f (patch)
tree50b78c8e42c108585b5dfd03304e3fc4d786eb89 /x11-drivers
parentppc/ppc64 stable wrt #354505 (diff)
downloadgentoo-2-497954347d4fb1eb31e26ba393d5a89bca56429f.tar.gz
gentoo-2-497954347d4fb1eb31e26ba393d5a89bca56429f.tar.bz2
gentoo-2-497954347d4fb1eb31e26ba393d5a89bca56429f.zip
Add patch to build on 2.6.38 as reported in bug #359095, many thanks to the people that refined patch and ebuild
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog7
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-10.12.ebuild6
-rw-r--r--x11-drivers/ati-drivers/files/ati-drivers-2.6.38.patch38
3 files changed, 49 insertions, 2 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
index fe0962ad480f..7fc77824dee9 100644
--- a/x11-drivers/ati-drivers/ChangeLog
+++ b/x11-drivers/ati-drivers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/ati-drivers
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.240 2011/03/21 13:39:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.241 2011/03/22 21:33:56 lu_zero Exp $
+
+ 22 Mar 2011; Luca Barbato <lu_zero@gentoo.org>
+ +files/ati-drivers-2.6.38.patch, ati-drivers-10.12.ebuild:
+ -m Add patch to build on 2.6.38 as reported in bug #359095, many thanks to
+ the people that refined patch and ebuild
21 Mar 2011; Markos Chandras <hwoarang@gentoo.org> ati-drivers-11.2.ebuild:
Stable on amd64 wrt bug #359059
diff --git a/x11-drivers/ati-drivers/ati-drivers-10.12.ebuild b/x11-drivers/ati-drivers/ati-drivers-10.12.ebuild
index 609afc0bc2ef..c489ab03275c 100644
--- a/x11-drivers/ati-drivers/ati-drivers-10.12.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-10.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-10.12.ebuild,v 1.3 2011/02/12 17:26:41 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-10.12.ebuild,v 1.4 2011/03/22 21:33:56 lu_zero Exp $
EAPI="2"
@@ -312,6 +312,10 @@ src_prepare() {
epatch "${FILESDIR}"/ati-drivers-2.6.37.patch || \
die "epatch ati-drivers-2.6.37.patch failed"
fi
+ if kernel_is ge 2 6 38 ; then
+ epatch "${FILESDIR}"/ati-drivers-2.6.38.patch || \
+ die "epatch ati-drivers-2.6.38.patch failed"
+ fi
# These are the userspace utilities that we also have source for.
# We rebuild these later.
diff --git a/x11-drivers/ati-drivers/files/ati-drivers-2.6.38.patch b/x11-drivers/ati-drivers/files/ati-drivers-2.6.38.patch
new file mode 100644
index 000000000000..fea6c26ffabf
--- /dev/null
+++ b/x11-drivers/ati-drivers/files/ati-drivers-2.6.38.patch
@@ -0,0 +1,38 @@
+--- ati.orig/common/lib/modules/fglrx/build_mod/firegl_public.c 2011-03-15 14:40:22.000000000 -0600
++++ ati/common/lib/modules/fglrx/build_mod/firegl_public.c 2011-03-15 14:38:09.000000000 -0600
+@@ -848,7 +848,7 @@
+ * happen much less frequent then without this workaround.
+ */
+ if (state == PM_EVENT_SUSPEND)
+- acquire_console_sem();
++ console_lock();
+
+ if (firegl_cail_powerdown(privdev, state))
+ ret = -EIO;
+@@ -870,7 +870,7 @@
+ }
+
+ if (state == PM_EVENT_SUSPEND)
+- release_console_sem();
++ console_unlock();
+
+ KCL_DEBUG_TRACEOUT(FN_FIREGL_ACPI, ret, NULL);
+
+@@ -894,7 +894,7 @@
+ if (PMSG_EVENT(pdev->dev.power.power_state) == 0) return 0;
+
+ if (PMSG_EVENT(pdev->dev.power.power_state) == PM_EVENT_SUSPEND)
+- acquire_console_sem();
++ console_lock();
+
+ #ifdef FIREGL_USWC_SUPPORT
+ // Restore the PAT after resuming from S3 or S4.
+@@ -919,7 +919,7 @@
+ firegl_cail_powerup(privdev);
+
+ if (PMSG_EVENT(pdev->dev.power.power_state) == PM_EVENT_SUSPEND)
+- release_console_sem();
++ console_unlock();
+
+ PMSG_EVENT(pdev->dev.power.power_state) = 0;
+ KCL_DEBUG_TRACEOUT(FN_FIREGL_ACPI, 0, NULL);