summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-08 07:08:32 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-08 07:08:32 +0000
commit68e18c9df9e30fa7910f6a3987d7ca28668f196c (patch)
tree444b4cdf41137c9b644d774477303bf739e567b5 /x11-drivers/xf86-video-sunffb
parentadded interim version (bug 72353) and removed broken 5.0.3 version (diff)
downloadgentoo-2-68e18c9df9e30fa7910f6a3987d7ca28668f196c.tar.gz
gentoo-2-68e18c9df9e30fa7910f6a3987d7ca28668f196c.tar.bz2
gentoo-2-68e18c9df9e30fa7910f6a3987d7ca28668f196c.zip
Initial commit for modular X.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-drivers/xf86-video-sunffb')
-rw-r--r--x11-drivers/xf86-video-sunffb/ChangeLog10
-rw-r--r--x11-drivers/xf86-video-sunffb/Manifest3
-rw-r--r--x11-drivers/xf86-video-sunffb/files/digest-xf86-video-sunffb-1.0.01
-rw-r--r--x11-drivers/xf86-video-sunffb/files/dri.patch12
-rw-r--r--x11-drivers/xf86-video-sunffb/xf86-video-sunffb-1.0.0.ebuild24
5 files changed, 50 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-sunffb/ChangeLog b/x11-drivers/xf86-video-sunffb/ChangeLog
new file mode 100644
index 000000000000..22550e7e4062
--- /dev/null
+++ b/x11-drivers/xf86-video-sunffb/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-drivers/xf86-video-sunffb
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-sunffb/ChangeLog,v 1.1 2005/08/08 07:08:32 spyderous Exp $
+
+*xf86-video-sunffb-1.0.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; +files/dri.patch,
+ +xf86-video-sunffb-1.0.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-drivers/xf86-video-sunffb/Manifest b/x11-drivers/xf86-video-sunffb/Manifest
new file mode 100644
index 000000000000..12b3e50dfe53
--- /dev/null
+++ b/x11-drivers/xf86-video-sunffb/Manifest
@@ -0,0 +1,3 @@
+MD5 81047a49b259046acf6b048032b81a93 xf86-video-sunffb-1.0.0.ebuild 549
+MD5 c3bdeda9f680af55a2ae7ce1cde6b1ae files/dri.patch 613
+MD5 8dfbaf078fd0f2b8389afc457b075454 files/digest-xf86-video-sunffb-1.0.0 76
diff --git a/x11-drivers/xf86-video-sunffb/files/digest-xf86-video-sunffb-1.0.0 b/x11-drivers/xf86-video-sunffb/files/digest-xf86-video-sunffb-1.0.0
new file mode 100644
index 000000000000..0b37e7d002ec
--- /dev/null
+++ b/x11-drivers/xf86-video-sunffb/files/digest-xf86-video-sunffb-1.0.0
@@ -0,0 +1 @@
+MD5 c4419ea048cc69e2b38b1ed6f98ea7d7 xf86-video-sunffb-1.0.0.tar.bz2 267141
diff --git a/x11-drivers/xf86-video-sunffb/files/dri.patch b/x11-drivers/xf86-video-sunffb/files/dri.patch
new file mode 100644
index 000000000000..c717732f1f89
--- /dev/null
+++ b/x11-drivers/xf86-video-sunffb/files/dri.patch
@@ -0,0 +1,12 @@
+diff -urN xf86-video-sunffb-0.0_pre20050726.orig/configure.ac xf86-video-sunffb-0.0_pre20050726/configure.ac
+--- xf86-video-sunffb-0.0_pre20050726.orig/configure.ac 2005-07-26 16:36:05.000000000 -0700
++++ xf86-video-sunffb-0.0_pre20050726/configure.ac 2005-07-27 13:50:24.000000000 -0700
+@@ -82,7 +82,7 @@
+
+ AM_CONDITIONAL(DRI, test x$DRI = xyes)
+ if test "$DRI" = yes; then
+- PKG_CHECK_MODULES(DRI, [libdrm])
++ PKG_CHECK_MODULES(DRI, [libdrm xf86driproto])
+ AC_DEFINE(XF86DRI,1,[Enable DRI driver support])
+ AC_DEFINE(XF86DRI_DEVEL,1,[Enable developmental DRI driver support])
+ fi
diff --git a/x11-drivers/xf86-video-sunffb/xf86-video-sunffb-1.0.0.ebuild b/x11-drivers/xf86-video-sunffb/xf86-video-sunffb-1.0.0.ebuild
new file mode 100644
index 000000000000..30624f0308b2
--- /dev/null
+++ b/x11-drivers/xf86-video-sunffb/xf86-video-sunffb-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-sunffb/xf86-video-sunffb-1.0.0.ebuild,v 1.1 2005/08/08 07:08:32 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for sunffb cards"
+KEYWORDS="~x86"
+IUSE="dri"
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}