summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-11-15 01:09:50 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-11-15 01:09:50 +0000
commitd999179e1d2515cefc1a851db99f154c0ebc8cbe (patch)
treefbe60d6159462f140377a395259132377bad4de7 /x11-drivers/xf86-input-synaptics
parentVersion bumped. Changed EAPI from 2 to 1. (diff)
downloadgentoo-2-d999179e1d2515cefc1a851db99f154c0ebc8cbe.tar.gz
gentoo-2-d999179e1d2515cefc1a851db99f154c0ebc8cbe.tar.bz2
gentoo-2-d999179e1d2515cefc1a851db99f154c0ebc8cbe.zip
First release candidate for the 1.0 release. With thanks to Donnie Berkholz for alerting me of the release.
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc4-00011-g3ad4f59-dirty x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index e2a06f6ce9aa..01429dd61dba 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.12 2008/09/16 10:45:01 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.13 2008/11/15 01:09:50 chainsaw Exp $
+
+*xf86-input-synaptics-0.99.1 (15 Nov 2008)
+
+ 15 Nov 2008; <chainsaw@gentoo.org> +xf86-input-synaptics-0.99.1.ebuild:
+ First release candidate for the 1.0 release. With thanks to Donnie
+ Berkholz for alerting me of the release.
*xf86-input-synaptics-0.15.2-r2 (16 Sep 2008)
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.1.ebuild
new file mode 100644
index 000000000000..6e1646ddc72f
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.1.ebuild,v 1.1 2008/11/15 01:09:50 chainsaw Exp $
+
+inherit toolchain-funcs eutils linux-info x-modular
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="MIT"
+IUSE="hal"
+RDEPEND="x11-libs/libXext
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ !x11-drivers/synaptics
+ x11-base/xorg-server
+ x11-proto/inputproto
+ >=sys-apps/sed-4"
+
+evdev-input_check() {
+ # Check kernel config for required event interface support (either
+ # built-in or as a module. Bug #134309.
+
+ ebegin "Checking kernel config for event device support"
+ linux_chkconfig_present INPUT_EVDEV
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "Synaptics driver requires event interface support."
+ ewarn "Please enable the event interface in your kernel config."
+ ewarn "The option can be found at:"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " -*- Generic input layer"
+ ewarn " <*> Event interface"
+ ewarn
+ ewarn "Then rebuild the kernel or install the module."
+ epause 5
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ evdev-input_check
+}
+
+src_unpack() {
+ x-modular_unpack_source
+}
+
+src_install() {
+ DOCS="INSTALL NEWS TODO README"
+ x-modular_src_install
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd "${FILESDIR}"/rc.init syndaemon
+ newconfd "${FILESDIR}"/rc.conf syndaemon
+
+ if use hal ; then
+ # Have HAL assign this driver to supported touchpads.
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ doins "${S}"/fdi/11-x11-synaptics.fdi
+ fi
+}