summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-09-14 19:54:23 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-09-14 19:54:23 +0000
commit5657243dc839333592d0c1d7769d4d533c1dbe05 (patch)
tree8851f1332e1b4df7632f30a4f213c9dbfd82c78a /x11-drivers/radeon-ucode
parentupdating requirements.txt stuffs (diff)
downloadgentoo-2-5657243dc839333592d0c1d7769d4d533c1dbe05.tar.gz
gentoo-2-5657243dc839333592d0c1d7769d4d533c1dbe05.tar.bz2
gentoo-2-5657243dc839333592d0c1d7769d4d533c1dbe05.zip
Add more ucode for recent hardware and new functions, bug #521296.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'x11-drivers/radeon-ucode')
-rw-r--r--x11-drivers/radeon-ucode/ChangeLog8
-rw-r--r--x11-drivers/radeon-ucode/radeon-ucode-20140823.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-drivers/radeon-ucode/ChangeLog b/x11-drivers/radeon-ucode/ChangeLog
index 424ebc50f221..86cd78e50990 100644
--- a/x11-drivers/radeon-ucode/ChangeLog
+++ b/x11-drivers/radeon-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/radeon-ucode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.39 2014/05/04 12:38:30 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.40 2014/09/14 19:54:23 chithanh Exp $
+
+*radeon-ucode-20140823 (14 Sep 2014)
+
+ 14 Sep 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +radeon-ucode-20140823.ebuild:
+ Add more ucode for recent hardware and new functions, bug #521296.
*radeon-ucode-20140430 (04 May 2014)
diff --git a/x11-drivers/radeon-ucode/radeon-ucode-20140823.ebuild b/x11-drivers/radeon-ucode/radeon-ucode-20140823.ebuild
new file mode 100644
index 000000000000..54538afda5ac
--- /dev/null
+++ b/x11-drivers/radeon-ucode/radeon-ucode-20140823.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/radeon-ucode-20140823.ebuild,v 1.1 2014/09/14 19:54:23 chithanh Exp $
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="IRQ microcode for r6xx/r7xx/Evergreen/N.Islands/S.Islands Radeon GPUs and APUs"
+HOMEPAGE="http://people.freedesktop.org/~agd5f/radeon_ucode/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="radeon-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /lib/firmware/radeon
+ FILES=( *.bin )
+ doins ${FILES[@]} || die "doins failed"
+}
+
+pkg_postinst() {
+ if linux_config_exists && linux_chkconfig_builtin DRM_RADEON; then
+ if ! linux_chkconfig_present FIRMWARE_IN_KERNEL || \
+ ! [[ "$(linux_chkconfig_string EXTRA_FIRMWARE)" == *_rlc.bin* ]]; then
+ ewarn "Your kernel has radeon DRM built-in but not the IRQ microcode."
+ ewarn "For kernel modesetting to work, please set in kernel config"
+ ewarn "CONFIG_FIRMWARE_IN_KERNEL=y"
+ ewarn "CONFIG_EXTRA_FIRMWARE_DIR=\"/lib/firmware\""
+ ewarn "CONFIG_EXTRA_FIRMWARE=\"${FILES[@]/#/radeon/}\""
+ ewarn "You may skip microcode files for which no hardware is installed."
+ ewarn "More information at http://wiki.gentoo.org/wiki/Radeon#Firmware"
+ fi
+ fi
+}