summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-05-10 23:20:50 +0000
committerMike Auty <ikelos@gentoo.org>2009-05-10 23:20:50 +0000
commita20f775026f8a615a9b7a180ef738f3b519f6575 (patch)
tree38a88dc9e07c8758dccc49035cd8aefadaf60b88 /x11-drivers/linuxwacom
parentWorking on this for ~amd64. (diff)
downloadgentoo-2-a20f775026f8a615a9b7a180ef738f3b519f6575.tar.gz
gentoo-2-a20f775026f8a615a9b7a180ef738f3b519f6575.tar.bz2
gentoo-2-a20f775026f8a615a9b7a180ef738f3b519f6575.zip
Ensure kernel checks only occur when USE=module. FIxes bug 268378.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'x11-drivers/linuxwacom')
-rw-r--r--x11-drivers/linuxwacom/ChangeLog8
-rw-r--r--x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild50
-rw-r--r--x11-drivers/linuxwacom/linuxwacom-0.8.2_p2.ebuild50
-rw-r--r--x11-drivers/linuxwacom/linuxwacom-0.8.3_p2.ebuild50
4 files changed, 81 insertions, 77 deletions
diff --git a/x11-drivers/linuxwacom/ChangeLog b/x11-drivers/linuxwacom/ChangeLog
index 2adc6f656a2a..898e33b96216 100644
--- a/x11-drivers/linuxwacom/ChangeLog
+++ b/x11-drivers/linuxwacom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-drivers/linuxwacom
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/ChangeLog,v 1.35 2009/04/28 09:22:51 ikelos Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/ChangeLog,v 1.36 2009/05/10 23:20:50 ikelos Exp $
+
+ 10 May 2009; Mike Auty <ikelos@gentoo.org> linuxwacom-0.8.2.ebuild,
+ linuxwacom-0.8.2_p2.ebuild, linuxwacom-0.8.3_p2.ebuild:
+ Ensure kernel checks only occur when USE=module.
28 Apr 2009; Mike Auty <ikelos@gentoo.org> linuxwacom-0.8.3_p2.ebuild:
Add in warning to remove existing wacom fdi files for latest linuxwacom.
diff --git a/x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild b/x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild
index ad7df8897c69..6b3a7f910ca6 100644
--- a/x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild
+++ b/x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild,v 1.6 2009/04/05 22:09:34 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/linuxwacom-0.8.2.ebuild,v 1.7 2009/05/10 23:20:50 ikelos Exp $
inherit eutils autotools toolchain-funcs linux-mod
@@ -30,35 +30,35 @@ S=${WORKDIR}/${P/_p/-}
MODULE_NAMES="wacom(input:${S}/src:${S}/src)"
wacom_check() {
- if use module ; then
- ebegin "Checking for wacom module"
- linux_chkconfig_module TABLET_USB_WACOM
- eend $?
-
- if [[ $? -ne 0 ]] || ! [ -f "/lib/modules/${KV}/kernel/drivers/input/tablet/wacom.ko" ]; then
- eerror "You need to have your kernel compiled with wacom as a module"
- eerror "to let linuxwacom overwrite it."
- eerror "Enable it in the kernel, found at:"
- eerror
- eerror " Device Drivers"
- eerror " Input device support"
- eerror " Tablets"
- eerror " <M> Wacom Intuos/Graphire tablet support (USB)"
- eerror
- eerror "(in the "USB support" page it is suggested to include also:"
- eerror "EHCI , OHCI , USB Human Interface Device+HID input layer)"
- eerror
- eerror "Then recompile kernel. Otherwise, remove the module USE flag."
- die "Wacom not compiled in kernel as a module!"
- fi
+ ebegin "Checking for wacom module"
+ linux_chkconfig_module TABLET_USB_WACOM
+ eend $?
+
+ if [[ $? -ne 0 ]] || ! [ -f "/lib/modules/${KV}/kernel/drivers/input/tablet/wacom.ko" ]; then
+ eerror "You need to have your kernel compiled with wacom as a module"
+ eerror "to let linuxwacom overwrite it."
+ eerror "Enable it in the kernel, found at:"
+ eerror
+ eerror " Device Drivers"
+ eerror " Input device support"
+ eerror " Tablets"
+ eerror " <M> Wacom Intuos/Graphire tablet support (USB)"
+ eerror
+ eerror "(in the "USB support" page it is suggested to include also:"
+ eerror "EHCI , OHCI , USB Human Interface Device+HID input layer)"
+ eerror
+ eerror "Then recompile kernel. Otherwise, remove the module USE flag."
+ die "Wacom not compiled in kernel as a module!"
fi
}
pkg_setup() {
- linux-mod_pkg_setup
- # echo "kernel version is ${KV} , name is ${KV%%-*}"
+ if use module; then
+ linux-mod_pkg_setup
+ wacom_check
+ # echo "kernel version is ${KV} , name is ${KV%%-*}"
+ fi
ewarn "Versions of linuxwacom >= 0.7.9 require gcc >= 4.2 to compile."
- wacom_check
}
src_unpack() {
diff --git a/x11-drivers/linuxwacom/linuxwacom-0.8.2_p2.ebuild b/x11-drivers/linuxwacom/linuxwacom-0.8.2_p2.ebuild
index 3cf1c15db59e..cae30140558d 100644
--- a/x11-drivers/linuxwacom/linuxwacom-0.8.2_p2.ebuild
+++ b/x11-drivers/linuxwacom/linuxwacom-0.8.2_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/linuxwacom-0.8.2_p2.ebuild,v 1.2 2009/04/16 06:08:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/linuxwacom-0.8.2_p2.ebuild,v 1.3 2009/05/10 23:20:50 ikelos Exp $
inherit eutils autotools toolchain-funcs linux-mod
@@ -30,35 +30,35 @@ S=${WORKDIR}/${P/_p/-}
MODULE_NAMES="wacom(input:${S}/src:${S}/src)"
wacom_check() {
- if use module ; then
- ebegin "Checking for wacom module"
- linux_chkconfig_module TABLET_USB_WACOM
- eend $?
-
- if [[ $? -ne 0 ]] || ! [ -f "/lib/modules/${KV}/kernel/drivers/input/tablet/wacom.ko" ]; then
- eerror "You need to have your kernel compiled with wacom as a module"
- eerror "to let linuxwacom overwrite it."
- eerror "Enable it in the kernel, found at:"
- eerror
- eerror " Device Drivers"
- eerror " Input device support"
- eerror " Tablets"
- eerror " <M> Wacom Intuos/Graphire tablet support (USB)"
- eerror
- eerror "(in the "USB support" page it is suggested to include also:"
- eerror "EHCI , OHCI , USB Human Interface Device+HID input layer)"
- eerror
- eerror "Then recompile kernel. Otherwise, remove the module USE flag."
- die "Wacom not compiled in kernel as a module!"
- fi
+ ebegin "Checking for wacom module"
+ linux_chkconfig_module TABLET_USB_WACOM
+ eend $?
+
+ if [[ $? -ne 0 ]] || ! [ -f "/lib/modules/${KV}/kernel/drivers/input/tablet/wacom.ko" ]; then
+ eerror "You need to have your kernel compiled with wacom as a module"
+ eerror "to let linuxwacom overwrite it."
+ eerror "Enable it in the kernel, found at:"
+ eerror
+ eerror " Device Drivers"
+ eerror " Input device support"
+ eerror " Tablets"
+ eerror " <M> Wacom Intuos/Graphire tablet support (USB)"
+ eerror
+ eerror "(in the "USB support" page it is suggested to include also:"
+ eerror "EHCI , OHCI , USB Human Interface Device+HID input layer)"
+ eerror
+ eerror "Then recompile kernel. Otherwise, remove the module USE flag."
+ die "Wacom not compiled in kernel as a module!"
fi
}
pkg_setup() {
- linux-mod_pkg_setup
- # echo "kernel version is ${KV} , name is ${KV%%-*}"
+ if use module; then
+ linux-mod_pkg_setup
+ wacom_check
+ # echo "kernel version is ${KV} , name is ${KV%%-*}"
+ fi
ewarn "Versions of linuxwacom >= 0.7.9 require gcc >= 4.2 to compile."
- wacom_check
}
src_unpack() {
diff --git a/x11-drivers/linuxwacom/linuxwacom-0.8.3_p2.ebuild b/x11-drivers/linuxwacom/linuxwacom-0.8.3_p2.ebuild
index 21b39a9a0624..3873147b729d 100644
--- a/x11-drivers/linuxwacom/linuxwacom-0.8.3_p2.ebuild
+++ b/x11-drivers/linuxwacom/linuxwacom-0.8.3_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/linuxwacom-0.8.3_p2.ebuild,v 1.2 2009/04/28 09:22:51 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/linuxwacom-0.8.3_p2.ebuild,v 1.3 2009/05/10 23:20:50 ikelos Exp $
inherit eutils autotools toolchain-funcs linux-mod
@@ -30,35 +30,35 @@ S=${WORKDIR}/${P/_p/-}
MODULE_NAMES="wacom(input:${S}/src:${S}/src)"
wacom_check() {
- if use module ; then
- ebegin "Checking for wacom module"
- linux_chkconfig_module TABLET_USB_WACOM
- eend $?
-
- if [[ $? -ne 0 ]] || ! [ -f "/lib/modules/${KV}/kernel/drivers/input/tablet/wacom.ko" ]; then
- eerror "You need to have your kernel compiled with wacom as a module"
- eerror "to let linuxwacom overwrite it."
- eerror "Enable it in the kernel, found at:"
- eerror
- eerror " Device Drivers"
- eerror " Input device support"
- eerror " Tablets"
- eerror " <M> Wacom Intuos/Graphire tablet support (USB)"
- eerror
- eerror "(in the "USB support" page it is suggested to include also:"
- eerror "EHCI , OHCI , USB Human Interface Device+HID input layer)"
- eerror
- eerror "Then recompile kernel. Otherwise, remove the module USE flag."
- die "Wacom not compiled in kernel as a module!"
- fi
+ ebegin "Checking for wacom module"
+ linux_chkconfig_module TABLET_USB_WACOM
+ eend $?
+
+ if [[ $? -ne 0 ]] || ! [ -f "/lib/modules/${KV}/kernel/drivers/input/tablet/wacom.ko" ]; then
+ eerror "You need to have your kernel compiled with wacom as a module"
+ eerror "to let linuxwacom overwrite it."
+ eerror "Enable it in the kernel, found at:"
+ eerror
+ eerror " Device Drivers"
+ eerror " Input device support"
+ eerror " Tablets"
+ eerror " <M> Wacom Intuos/Graphire tablet support (USB)"
+ eerror
+ eerror "(in the "USB support" page it is suggested to include also:"
+ eerror "EHCI , OHCI , USB Human Interface Device+HID input layer)"
+ eerror
+ eerror "Then recompile kernel. Otherwise, remove the module USE flag."
+ die "Wacom not compiled in kernel as a module!"
fi
}
pkg_setup() {
- linux-mod_pkg_setup
- # echo "kernel version is ${KV} , name is ${KV%%-*}"
+ if use module; then
+ linux-mod_pkg_setup
+ wacom_check
+ # echo "kernel version is ${KV} , name is ${KV%%-*}"
+ fi
ewarn "Versions of linuxwacom >= 0.7.9 require gcc >= 4.2 to compile."
- wacom_check
}
src_unpack() {