summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-05-06 08:16:56 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-05-06 08:16:56 +0000
commit7f1177246977922592cacbc36f6d1760199f1dc9 (patch)
treecbd4eb3102a7d68ca3cdead6818d5c37b7121639 /x11-apps
parentmake fdo-mime.eclass ready for eclass-manpages, bug #211223, thank mren for r... (diff)
downloadgentoo-2-7f1177246977922592cacbc36f6d1760199f1dc9.tar.gz
gentoo-2-7f1177246977922592cacbc36f6d1760199f1dc9.tar.bz2
gentoo-2-7f1177246977922592cacbc36f6d1760199f1dc9.zip
Fix xdm init-script to be run after lircmd instead of just lircd to be able to use virtual lirc mouse device, Bug #180163.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog9
-rwxr-xr-xx11-apps/xinit/files/xdm.initd-2204
-rw-r--r--x11-apps/xinit/xinit-1.0.8-r3.ebuild63
3 files changed, 275 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 03b07632021b..272b07c6d048 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.115 2008/04/09 02:08:44 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.116 2008/05/06 08:16:56 zzam Exp $
+
+*xinit-1.0.8-r3 (06 May 2008)
+
+ 06 May 2008; Matthias Schwarzott <zzam@gentoo.org> +files/xdm.initd-2,
+ +xinit-1.0.8-r3.ebuild:
+ Fix xdm init-script to be run after lircmd instead of just lircd to be
+ able to use virtual lirc mouse device, Bug #180163.
*xinit-1.0.8-r2 (09 Apr 2008)
diff --git a/x11-apps/xinit/files/xdm.initd-2 b/x11-apps/xinit/files/xdm.initd-2
new file mode 100755
index 000000000000..5bbee1243aec
--- /dev/null
+++ b/x11-apps/xinit/files/xdm.initd-2
@@ -0,0 +1,204 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/xdm.initd-2,v 1.1 2008/05/06 08:16:56 zzam Exp $
+
+# This is here to serve as a note to myself, and future developers.
+#
+# Any Display manager (gdm,kdm,xdm) has the following problem: if
+# it is started before any getty, and no vt is specified, it will
+# usually run on vt2. When the getty on vt2 then starts, and the
+# DM is already started, the getty will take control of the keyboard,
+# leaving us with a "dead" keyboard.
+#
+# Resolution: add the following line to /etc/inittab
+#
+# x:a:once:/etc/X11/startDM.sh
+#
+# and have /etc/X11/startDM.sh start the DM in daemon mode if
+# a lock is present (with the info of what DM should be started),
+# else just fall through.
+#
+# How this basically works, is the "a" runlevel is a additional
+# runlevel that you can use to fork processes with init, but the
+# runlevel never gets changed to this runlevel. Along with the "a"
+# runlevel, the "once" key word means that startDM.sh will only be
+# run when we specify it to run, thus eliminating respawning
+# startDM.sh when "xdm" is not added to the default runlevel, as was
+# done previously.
+#
+# This script then just calls "telinit a", and init will run
+# /etc/X11/startDM.sh after the current runlevel completes (this
+# script should only be added to the actual runlevel the user is
+# using).
+#
+# Martin Schlemmer
+# aka Azarah
+# 04 March 2002
+
+
+# Start X Font Server before X
+depend() {
+ need localmount
+
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ # (#139824) Start after ypbind and autofs for network authentication
+ # (#145219 #180163) Could use lirc mouse as input device
+ # (#70689 comment #92) Start after consolefont to avoid display corruption
+ after bootmisc consolefont modules netmount
+ after readahead-list ypbind autofs openvpn gpm lircmd
+ before alsasound
+
+ # Start before X
+ use acpid consolekit hald xfs
+}
+
+setup_dm() {
+ local MY_XDM="$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')"
+
+ # Load our root path from profile.env
+ # Needed for kdm
+ PATH="${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")"
+
+ case "${MY_XDM}" in
+ kdm|kde|kde2|kde3)
+ EXE="$(which kdm)"
+ # kdm takes too long to create a pidfile for baselayout-2
+ #PIDFILE=/var/run/kdm.pid
+ PIDFILE=
+ ;;
+ kdm-*)
+ EXE="/usr/kde/${MY_XDM#kdm-}/bin/kdm"
+ PIDFILE=
+ ;;
+ entrance*)
+ EXE=/usr/sbin/entranced
+ PIDFILE=/var/lib/entranced.pid
+ ;;
+ gdm|gnome)
+ EXE=/usr/bin/gdm
+ [ "${RC_UNAME}" != "Linux" ] && NAME=gdm-binary
+ PIDFILE=/var/run/gdm.pid
+ ;;
+ wdm)
+ EXE=/usr/bin/wdm
+ PIDFILE=
+ ;;
+ *)
+ EXE=
+ # Fix #65586, where MY_XDM is empty so EXE=somedir
+ [ -x "/usr/bin/${MY_XDM}" ] && [ -f "/usr/bin/${MY_XDM}" ] \
+ && EXE="/usr/bin/${MY_XDM}"
+ if [ -z "${EXE}" ] ; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ fi
+ ;;
+ esac
+
+ if ! [ -x "${EXE}" ] ; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ fi
+}
+
+cmdline_opt() {
+ if [ $# -ne 1 ] || ! [ -r /proc/cmdline ]; then
+ return 1
+ fi
+
+ for opt in $(cat /proc/cmdline) ; do
+ [ "${opt}" = "${1}" ] && return 0
+ done
+
+ return 1
+}
+
+# Check to see if something is defined on our VT
+vtstatic() {
+ if [ -e /etc/inittab ] ; then
+ grep -Eq "^[^#]+.*\<tty$1\>" /etc/inittab
+ elif [ -e /etc/ttys ] ; then
+ grep -q "^ttyv$(($1 - 1))" /etc/ttys
+ else
+ return 1
+ fi
+}
+
+start() {
+ local EXE= NAME= PIDFILE=
+ setup_dm
+
+ if cmdline_opt nox ; then
+ einfo "Skipping ${EXE}, received 'nox'"
+ return 0
+ fi
+
+ ebegin "Setting up ${EXE##*/}"
+ #save the prefered DM
+ save_options "service" "${EXE}"
+ save_options "name" "${NAME}"
+ save_options "pidfile" "${PIDFILE}"
+
+ if [ -n "${CHECKVT-y}" ] ; then
+ if vtstatic "${CHECKVT:-7}" ; then
+ if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ] ; then
+ ewarn "Something is already defined on VT ${CHECKVT:-7}, will start X later"
+ telinit a >/dev/null 2>/dev/null
+ return 0
+ else
+ eerror "Something is already defined on VT ${CHECKVT:-7}, not starting"
+ return 1
+ fi
+ fi
+ fi
+
+ /etc/X11/startDM.sh
+ eend 0
+}
+
+stop() {
+ local retval=0
+ local curvt=
+ if [ -t 0 ] ; then
+ if type fgconsole >/dev/null 2>/dev/null ; then
+ curvt="$(fgconsole 2>/dev/null)"
+ else
+ curvt="$(tty)"
+ case "${curvt}" in
+ /dev/ttyv[0-9]*) curvt="${curvt#/dev/ttyv*}" ;;
+ *) curvt= ;;
+ esac
+ fi
+ fi
+ local myexe="$(get_options "service")"
+ local myname="$(get_options "name")"
+ local mypidfile="$(get_options "pidfile")"
+ local myservice=${myexe##*/}
+
+ [ -z "${myexe}" ] && return 0
+
+ ebegin "Stopping ${myservice}"
+
+ if start-stop-daemon --quiet --test --stop --exec "${myexe}" ; then
+ start-stop-daemon --stop --exec "${myexe}" --retry TERM/5/TERM/5 \
+ ${mypidfile:+--pidfile} ${mypidfile} \
+ ${myname:+--name} ${myname}
+ retval=$?
+ fi
+
+ # switch back to original vt
+ if [ -n "${curvt}" ] ; then
+ if type chvt >/dev/null 2>/dev/null ; then
+ chvt "${curvt}"
+ else
+ vidcontrol -s "$((${curvt} + 1))"
+ fi
+ fi
+ eend ${retval} "Error stopping ${myservice}"
+
+ return ${retval}
+}
+
+# vim: set ts=4 :
diff --git a/x11-apps/xinit/xinit-1.0.8-r3.ebuild b/x11-apps/xinit/xinit-1.0.8-r3.ebuild
new file mode 100644
index 000000000000..c10c27fee022
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.0.8-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.8-r3.ebuild,v 1.1 2008/05/06 08:16:56 zzam Exp $
+
+# Must be before x-modular eclass is inherited
+# This is enabled due to modified Makefile.am from the patches
+SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="hal minimal pam"
+
+RDEPEND="x11-apps/xauth
+ x11-libs/libX11
+ hal? ( sys-auth/consolekit )"
+DEPEND="${RDEPEND}"
+PDEPEND="!minimal? ( x11-wm/twm
+ x11-apps/xclock
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-terms/xterm )"
+
+PATCHES="${FILESDIR}/nolisten-tcp-and-black-background.patch
+ ${FILESDIR}/gentoo-startx-customization-1.0.8.patch
+ ${FILESDIR}/xinit-1.0.4-console-kit.patch"
+
+CONFIGURE_OPTIONS="$(use_with hal consolekit)"
+
+pkg_setup() {
+ if use hal; then
+ if ! built_with_use sys-apps/dbus X ; then
+ eerror "You MUST build sys-apps/dbus with the X USE flag enabled."
+ die "You MUST build sys-apps/dbus with the X USE flag enabled."
+ fi
+ fi
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" "${S}/Makefile.am"
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession || die
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xinitrc || die
+ newinitd "${FILESDIR}"/xdm.initd-2 xdm
+ newconfd "${FILESDIR}"/xdm.confd-1 xdm
+ newpamd "${FILESDIR}"/xserver.pamd xserver
+ newenvd "${FILESDIR}"/xsession.env.d 90xsession
+}