summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-10-22 17:55:49 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-10-22 17:55:49 +0000
commit9d47e6e18548d13ab1fa38bf8d2c5057f738b1c3 (patch)
treef4aba7d35192d69b5dcf872a2aa610af0a08a235 /x11-apps/xinit
parentinitial ebuild; moved from overlay gentoo-de/vdr-testing (diff)
downloadgentoo-2-9d47e6e18548d13ab1fa38bf8d2c5057f738b1c3.tar.gz
gentoo-2-9d47e6e18548d13ab1fa38bf8d2c5057f738b1c3.tar.bz2
gentoo-2-9d47e6e18548d13ab1fa38bf8d2c5057f738b1c3.zip
Various bumps from upstream with minor changes.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'x11-apps/xinit')
-rw-r--r--x11-apps/xinit/ChangeLog8
-rw-r--r--x11-apps/xinit/files/digest-xinit-1.0.33
-rw-r--r--x11-apps/xinit/xinit-1.0.3.ebuild49
3 files changed, 59 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 40a26d3f691c..e4e95f14eecb 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.70 2006/10/10 23:55:19 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.71 2006/10/22 17:55:49 joshuabaergen Exp $
+
+*xinit-1.0.3 (21 Oct 2006)
+
+ 21 Oct 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xinit-1.0.3.ebuild:
+ Version bump.
10 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>;
xinit-1.0.2-r6.ebuild:
diff --git a/x11-apps/xinit/files/digest-xinit-1.0.3 b/x11-apps/xinit/files/digest-xinit-1.0.3
new file mode 100644
index 000000000000..c80598bf332d
--- /dev/null
+++ b/x11-apps/xinit/files/digest-xinit-1.0.3
@@ -0,0 +1,3 @@
+MD5 f04a903cc0e18b3c338f58eb90f6caf8 xinit-1.0.3.tar.bz2 97629
+RMD160 e0299e1cb07d12400b9513752dccde1dc0d9cb78 xinit-1.0.3.tar.bz2 97629
+SHA256 c77a58cba815eb1dde2242a819e80d7d84d753678837ac24d385e3ec65d33186 xinit-1.0.3.tar.bz2 97629
diff --git a/x11-apps/xinit/xinit-1.0.3.ebuild b/x11-apps/xinit/xinit-1.0.3.ebuild
new file mode 100644
index 000000000000..08b74b544c6c
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.3.ebuild,v 1.1 2006/10/22 17:55:49 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+# This is enabled due to modified Makefile.am from the patches
+SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="minimal"
+
+RDEPEND="x11-apps/xauth
+ x11-libs/libX11
+ !minimal? ( x11-wm/twm
+ x11-apps/xclock
+ x11-apps/xrdb
+ x11-apps/xsm )"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-terms/xterm"
+
+PATCHES="${FILESDIR}/nolisten-tcp-and-black-background.patch
+ ${FILESDIR}/gentoo-startx-customization-0.99.4.patch"
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" ${S}/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe ${FILESDIR}/chooser.sh ${FILESDIR}/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/Xsession
+ exeinto /etc/X11/xinit
+ doexe ${FILESDIR}/xinitrc
+ newinitd ${FILESDIR}/xdm.start xdm
+ newconfd ${FILESDIR}/xdm.confd xdm
+ newpamd ${FILESDIR}/xserver.pamd xserver
+}