summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:40:31 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:40:31 +0000
commit8b1b3f99ac23fdca00f3ee5a635143cc66bd8940 (patch)
treeaf6472a6e0b638ba490d060c683058e044324626 /x11-apps/xedit/xedit-1.0.2.ebuild
parentVersion bump. Includes quite a few bugfixes. (diff)
downloadgentoo-2-8b1b3f99ac23fdca00f3ee5a635143cc66bd8940.tar.gz
gentoo-2-8b1b3f99ac23fdca00f3ee5a635143cc66bd8940.tar.bz2
gentoo-2-8b1b3f99ac23fdca00f3ee5a635143cc66bd8940.zip
Version bump. Includes a Cygwin build fix.
(Portage version: 2.1_pre10)
Diffstat (limited to 'x11-apps/xedit/xedit-1.0.2.ebuild')
-rw-r--r--x11-apps/xedit/xedit-1.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-apps/xedit/xedit-1.0.2.ebuild b/x11-apps/xedit/xedit-1.0.2.ebuild
new file mode 100644
index 000000000000..f89119ec19c0
--- /dev/null
+++ b/x11-apps/xedit/xedit-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/xedit-1.0.2.ebuild,v 1.1 2006/04/29 16:40:31 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xedit application"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXprintUtil
+ x11-libs/libXaw
+ xprint? ( x11-libs/libXprintUtil )"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+#src_compile() {
+# x-modular_src_configure
+# emake -j1 || die "emake failed"
+#}