summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-12-17 22:25:13 +0000
committerMichał Górny <mgorny@gentoo.org>2010-12-17 22:25:13 +0000
commit8c3437ff23cad58cf1374adcadb816d11b277f13 (patch)
treef48b20df9ac25f586aba33282a810a4d831e1e08 /x11-apps/xdm
parentMask dev-lang/v8 dev channel versions. (diff)
downloadgentoo-2-8c3437ff23cad58cf1374adcadb816d11b277f13.tar.gz
gentoo-2-8c3437ff23cad58cf1374adcadb816d11b277f13.tar.bz2
gentoo-2-8c3437ff23cad58cf1374adcadb816d11b277f13.zip
Version bump with an ebuild cleanup. Migrate to the xorg-2 eclass, remove patches which are (hopefully) no longer necessary.
(Portage version: 2.2.0_alpha7_p8/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/ChangeLog8
-rw-r--r--x11-apps/xdm/xdm-1.1.10.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index 6306a22dd8ff..818d116fcfb3 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.106 2010/02/21 16:48:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.107 2010/12/17 22:25:13 mgorny Exp $
+
+*xdm-1.1.10 (17 Dec 2010)
+
+ 17 Dec 2010; Michał Górny <mgorny@gentoo.org> +xdm-1.1.10.ebuild:
+ Version bump with an ebuild cleanup. Migrate to the xorg-2 eclass, remove
+ patches which are (hopefully) no longer necessary.
21 Feb 2010; Raúl Porcel <armin76@gentoo.org> xdm-1.1.9.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #302046
diff --git a/x11-apps/xdm/xdm-1.1.10.ebuild b/x11-apps/xdm/xdm-1.1.10.ebuild
new file mode 100644
index 000000000000..034a0dc493b8
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.10.ebuild,v 1.1 2010/12/17 22:25:13 mgorny Exp $
+
+EAPI=3
+
+inherit multilib xorg-2 pam
+
+DEFAULTVT="vt7"
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 pam"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg
+ x11-apps/xconsole"
+DEPEND="${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+PATCHES=( "${FILESDIR}"/xwilling-hang.patch )
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with pam)
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm"
+}
+
+src_install() {
+ xorg-2_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession || die
+ newpamd "${FILESDIR}"/xdm.pamd xdm || die
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+}