summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-01-24 18:09:02 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-01-24 18:09:02 +0000
commitcecee3033d339c8f69bfb4f908f674d7425af7d3 (patch)
tree1fd0338c2c246b032711e60e8eafedd0b13dda19 /www-servers
parentAdded modular X dependencies and some general cleanup. (diff)
downloadgentoo-2-cecee3033d339c8f69bfb4f908f674d7425af7d3.tar.gz
gentoo-2-cecee3033d339c8f69bfb4f908f674d7425af7d3.tar.bz2
gentoo-2-cecee3033d339c8f69bfb4f908f674d7425af7d3.zip
* bump
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest2
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.231
-rw-r--r--www-servers/nginx/nginx-0.3.23.ebuild72
4 files changed, 81 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index c69525666afe..77e03cf9c593 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.67 2006/01/18 14:31:09 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.68 2006/01/24 18:09:02 voxus Exp $
+
+*nginx-0.3.23 (24 Jan 2006)
+
+ 24 Jan 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.23.ebuild:
+ Version bump.
*nginx-0.3.22 (18 Jan 2006)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 78e7632ad146..8039fd52ff96 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -4,6 +4,7 @@ MD5 86fb37c347608004443f47aabae2fec7 files/digest-nginx-0.2.6 63
MD5 1bb0edeb44d5da60091b0c0d24e87c4f files/digest-nginx-0.3.12 64
MD5 676aa9e60aa117c23ab3a5af4c3c893b files/digest-nginx-0.3.15 64
MD5 bd14300806e989be2fcea34593a87eb2 files/digest-nginx-0.3.22 64
+MD5 2d8bce3492e8853e2f44e04dd4d26f73 files/digest-nginx-0.3.23 64
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
MD5 accbe26c88f0598f5559c4f00d226313 files/nginx.conf-r1 966
@@ -13,3 +14,4 @@ MD5 6460bce607f17843cd0c22395e6122e0 nginx-0.2.6.ebuild 1934
MD5 095ed1434baabf705fdbe6c4fbc92cf1 nginx-0.3.12.ebuild 1935
MD5 b24f35c96ef3f22c3c1e523ac45da59b nginx-0.3.15.ebuild 1937
MD5 04c1144cc9bf2e0c14e6a3ae151627d6 nginx-0.3.22.ebuild 2058
+MD5 04c1144cc9bf2e0c14e6a3ae151627d6 nginx-0.3.23.ebuild 2058
diff --git a/www-servers/nginx/files/digest-nginx-0.3.23 b/www-servers/nginx/files/digest-nginx-0.3.23
new file mode 100644
index 000000000000..e65ee8195d0b
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.23
@@ -0,0 +1 @@
+MD5 d7d1659c9a85c0a536dce7b40e489f15 nginx-0.3.23.tar.gz 372316
diff --git a/www-servers/nginx/nginx-0.3.23.ebuild b/www-servers/nginx/nginx-0.3.23.ebuild
new file mode 100644
index 000000000000..ac24b7c136d7
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.23.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.23.ebuild,v 1.1 2006/01/24 18:09:02 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r1 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}