summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-27 08:53:15 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-27 08:53:15 +0000
commitcb620a89a489664417b6ab85a7329486b35eea46 (patch)
tree9a13963a16f4d78dbc7dc74d9a6492a2e6d09424 /www-servers
parentFix linguas patch. Bug #413283 (diff)
downloadgentoo-2-cb620a89a489664417b6ab85a7329486b35eea46.tar.gz
gentoo-2-cb620a89a489664417b6ab85a7329486b35eea46.tar.bz2
gentoo-2-cb620a89a489664417b6ab85a7329486b35eea46.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/thin/ChangeLog9
-rw-r--r--www-servers/thin/thin-1.3.1.ebuild81
2 files changed, 88 insertions, 2 deletions
diff --git a/www-servers/thin/ChangeLog b/www-servers/thin/ChangeLog
index 828c869c6536..7729608f5d72 100644
--- a/www-servers/thin/ChangeLog
+++ b/www-servers/thin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/thin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/ChangeLog,v 1.18 2011/12/25 11:41:08 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/ChangeLog,v 1.19 2012/04/27 08:53:15 graaff Exp $
+
+*thin-1.3.1 (27 Apr 2012)
+
+ 27 Apr 2012; Hans de Graaff <graaff@gentoo.org> +thin-1.3.1.ebuild:
+ Version bump.
25 Dec 2011; Hans de Graaff <graaff@gentoo.org> -thin-1.2.5-r1.ebuild:
Remove old version.
diff --git a/www-servers/thin/thin-1.3.1.ebuild b/www-servers/thin/thin-1.3.1.ebuild
new file mode 100644
index 000000000000..486e68f4fb97
--- /dev/null
+++ b/www-servers/thin/thin-1.3.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/thin-1.3.1.ebuild,v 1.1 2012/04/27 08:53:15 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast and very simple Ruby web server"
+HOMEPAGE="http://code.macournoyer.com/thin/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+# The runtime dependencies are used at build-time as well since the
+# Rakefile loads thin!
+mydeps=">=dev-ruby/daemons-1.0.9
+ >=dev-ruby/rack-1.0.0
+ >=dev-ruby/eventmachine-0.12.6
+ virtual/ruby-ssl"
+
+ruby_add_rdepend "${mydeps}"
+ruby_add_bdepend "${mydeps}
+ dev-ruby/rake-compiler
+ test? ( dev-ruby/rspec:0 )"
+
+all_ruby_prepare() {
+ # Fix Ragel-based parser generation (uses a *very* old syntax that
+ # is not supported in Gentoo)
+ sed -i -e 's: | rlgen-cd::' Rakefile || die
+
+ # Fix specs' dependencies so that the extension is not rebuilt
+ # when running tests
+ sed -i -e '/:spec =>/s:^:#:' tasks/spec.rake || die
+
+ # Fix rspec version to allow newer 1.x versions
+ sed -i -e '/gem "rspec"/ s/1.2.9/1.0/' tasks/spec.rake spec/spec_helper.rb || die
+
+ # Disable a test that is known for freezing the testsuite,
+ # reported upstream.
+ sed -i \
+ -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
+ spec/daemonizing_spec.rb || die
+
+ # Pipelining specs don't work. Avoid them for now since this is not
+ # a regression. https://github.com/macournoyer/thin/issues/40
+ rm spec/server/pipelining_spec.rb || die
+
+ # nasty but too complex to fix up for now :(
+ use test || rm tasks/spec.rake
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "rake compile failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ keepdir /etc/thin
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ einfo
+ elog "Thin is now shipped with init scripts."
+ elog "The default script (/etc/init.d/thin) will start all servers that have"
+ elog "configuration files in /etc/thin/. You can symlink the init script to"
+ elog "files of the format 'thin.SERVER' to be able to start individual servers."
+ elog "See /etc/conf.d/thin for more configuration options."
+ einfo
+}